CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Dependencies problem when install crossover in Ubuntu 16.04 64bit

sudo dpkg -i crossover_17.0.0-1.deb

Selecting previously unselected package crossover:i386.
(Reading database ... 281673 files and directories currently installed.)
Preparing to unpack crossover_17.0.0-1.deb ...
Unpacking crossover:i386 (17.0.0-1) ...
dpkg: dependency problems prevent configuration of crossover:i386:
 crossover:i386 depends on libxext6 | xlibs.
 crossover:i386 depends on libxi6.
 crossover:i386 depends on libfreetype6.
 crossover:i386 depends on libcups2.
 crossover:i386 depends on liblcms2-2.
 crossover:i386 depends on libglu1-mesa.
 crossover:i386 depends on libxcursor1.
 crossover:i386 depends on libxrandr2.

dpkg: error processing package crossover:i386 (--install):
 dependency problems - leaving unconfigured
Processing triggers for doc-base (0.10.7) ...
Processing 1 added doc-base file...
Errors were encountered while processing:
 crossover:i386

Try to fix the dependencies by :


sudo apt-get -f install            

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages will be REMOVED:
  crossover:i386
0 upgraded, 0 newly installed, 1 to remove and 23 not upgraded.
1 not fully installed or removed.
After this operation, 508 MB disk space will be freed.
Do you want to continue? [Y/n] n
Abort.

Then I installed the dependencies manully one by one, all of them are already in my system:


Reading package lists... Done
Building dependency tree       
Reading state information... Done
libxrandr2 is already the newest version (2:1.5.0-1).
0 upgraded, 0 newly installed, 0 to remove and 23 not upgraded.

Now I really don't have any clue to fix this, anyone could help me please?

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjoiZW4iLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNzE1NzkzNDc5LCJjc3JmX3Rva2VuIjoidFBFUHlxTXBBdkV6VGY0dCIsImdkcHIiOjB9