CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Battlenet error a required dll could not be found

Hi,
I am having a bit of an issue. I had Battlenet and Hearthstone installed in cxo and working. This morning I got a "a required dll could not be found." error that stops battlenet from launching.
Things I have tried that have not fixed the issue:
Changed the windows version to xp and Windows 10 (it was on Windows 7 with the same error)
Delete the bottle and try to reinstall
Delete the .cxoffice folder in home and try to reinstall
Search google and read lots of pages but nothing seems to work.

Running Linux Mint 18 Mate 64bit and everything is up to date. Strangely everything works fine under Wine Staging 2.21 in a 32bit install. Not sure if the cxo install is 32 or 64bit.

Thanks in advance.

looks like not much support...

try this
https://www.codeweavers.com/compatibility/crossover/forum/hearthstone?msg=204455

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjoiZW4iLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNzE1NzkzNDc5LCJjc3JmX3Rva2VuIjoiVnZ0cWt4QmhCS0tUa1Q4biIsImdkcHIiOjB9