CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Crossover Unlock fails

Hi everyone,

I'm on Manjaro 17.1 with Gnome and I can't unlock the Crossover 17.0.0 test version to a paid full version.

I ordered a license for Linux but got a Mac license first. After writing a mail to the support they switched the license to a Linux one, but unlock does not work with this one too. Trying to unlock with my codeweavers account credentials gives me a "Registration failed" error after some seconds of waiting.

Any ideas? :(

Greetings,
Sascha

It does not matter - licenses are the same. The license is personal and can be unlocked on your personal computers be it 1 or 5.

To unlock you use your email address used at purchase and your password for said email.

It is the same you use to login to codeweavers.com and you can use the forgot password to get a new one and set it.

That's the problem, I used the exact email and password I use to login to the website, but I get an error saying "Registration failed" if I try to unlock CrossOver.

image


This issue has been forwarded to the Official CodeWeavers Ticket System. If you have observed this issue and would like to report it as well, please open a support ticket or send an email to info@codeweavers.com with a description of what you are seeing and a link to this post.

Thank you!
The CodeWeavers Team

I vaguely remember an issue on Ubuntu where people couldn't register because of a problem with privileges on certain files. It was a while back.

With that in mind, I would ask how you installed Crossover. Did you use the AUR or the bin file.

In any case, if memory serves, you can try to register with root privileges (assuming a system wide install):

sudo /opt/cxoffice/bin/cxregister

1

I installed it via AUR. Should I have used the bin file?

sudo /opt/cxoffice/bin/cxregister gives me this error

No protocol specified
No protocol specified
cxregister:error: Verify $DISPLAY: it is not set, invalid or you are not allowed to access it

I have no idea what those errors are, and obviously my original assumption isn't valid.

With that in mind, you have nothing to loose to try the bin file but, at this point, I'm not convinced it will solve the issue. Mind you, as an Arch user, I do use the bin file, and I install without root privileges, which means my install is in my home ( ~/.cxoffice ).

That being said, I would try a support ticket. Arch and it's derivatives aren't officially supported, but if the staff have any idea of what is going on, I'm sure they'll do their best to solve this for you. I would point them to this thread, or at least be specific as to what you have tried and the errors you got.

In any case, getting Crossover to register should be entirely possible on Manjaro, I'm sure there's a solution.

Sascha Smutny wrote:

I installed it via AUR. Should I have used the bin file?

sudo /opt/cxoffice/bin/cxregister gives me this error

No protocol specified
No protocol specified
cxregister:error: [b]Verify $DISPLAY: it is not set, invalid or you
are not allowed to access it[/b]

I am Manjaro user too. Back in my pure Arch days I tried installing via AUR and while it worked it was a pain to work with.

From the error message I have highlighted I think you are using Wayland and Wayland does not allow Gtk windows as root. Pacman-mirrors has the same issue with the -i argument.

This brings me to my point being - uninstall Crossover - and reinstall using the bin file from your accounts download section.

Ok, did uninstall the AUR version and installed via bin file from homepage.

And what should I say... works like a charm. :)

Thanks everyone!

I am having the same problem, except I have installed the .deb file (crossover_17.0.0-1.deb) on Linux Mint 18.3.

I even tried doing an "apt purge crossover" and then reinstalling, still doesn't run the "unlock"/

Let me know what debug info you need.

Hey James,

Since Mint is a supported distro, you should go straight for a support ticket. Besides, I seriously doubt the problem on Manjaro has anything to do with Mint.

Speaking only for myself, I haven't used a Debian/Ubuntu based distro in years, so I doubt I would be much help.

1 to 10 of 10

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjoiZW4iLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNzE1NzkzNDc5LCJjc3JmX3Rva2VuIjoiVmJ3dFdVdW15V0tKNTdiaCIsImdkcHIiOjB9