CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

I can't get Overwatch (or even battle.net) to run. Is this a known issue, or am I doing something wrong?

I've installed Overwatch setup into a Windows 8 bottle, and it only runs long enough to download battle.net before it crashes. I've followed the install instructions provided by Crossover. What am I doing wrong?

Here's the debug log
https://drive.google.com/open?id=0B7LRd9PCwfpSSWZpdkV1VklEeTg

I've also tried this in Vista and Windows 7 bottles, with little success.

Some games have started enforcing DirectX 10/11 requirements after updates, apparently. This might be related, perhaps?

I also have problems running the most recent version of battle.net. My goal is to play WoW. I was skipping the Battle.net launcher as a workaround, but they just patched the game and I have to go through Battle.net, and now I'm stuck out.

Which version of CrossOver is everyone running? What OS? I'm using Battle.net on Ubuntu 16.10 32-bit with CrossOver 16.0.0 under a Windows XP bottle. No issues with Battle.net or World of Warcraft since the most recent update. Everything works okay.

Well I had BNet using Win7 (32) and was forced to revert to XP (32).

Leo Shapiro wrote:

Some games have started enforcing DirectX 10/11 requirements after
updates, apparently. This might be related, perhaps?

This is the reason. OW is DX11 only.

Battle.net should run under an XP bottle in either 32/64-bit, but will not run in win 7/8/10 bottles.

Do you have the system requirements installed? Working with crossover and wine i find there are some files that need to be installed even if they don't say anything about them kinda hard to guess what they may be. Internet explorer and flash are two of them if you know where a trial is i could try to install it I looked for a download of it to try but couldn't find one.

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjoiZW4iLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNzE1NzkzNDc5LCJjc3JmX3Rva2VuIjoiVVJ0a0tlMnBxZHc1TU41WCIsImdkcHIiOjB9