CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Crossover can't find lib32nss-mdns

As it says in the title, it cannot install lib32nss-mdns because it's missing in the repositories, as my search has yielded there is no such package in Xenial anymore, as can be seen here.
Using Xubuntu 16.04.

Every time I launch Crossover it tries to install lib32nss-mdns, but every time it fails to do so.
What's annoying about this is that it also tries to install the package every time I want to install a new game via Crossover.
I'm not sure whether it prevents the other packages from being installed afterwards either.


CrossOver Linux 15.1.0
Install location: /opt/cxoffice
64-bit OS
Desktop session: xubuntu
Window manager: Xfwm4
Locale: de_DE.UTF-8

Contents of /etc/os-release:
NAME="Ubuntu"
VERSION="16.04 LTS (Xenial Xerus)"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 16.04 LTS"
VERSION_ID="16.04"
HOME_URL="http://www.ubuntu.com/"
SUPPORT_URL="http://help.ubuntu.com/"
BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/"
UBUNTU_CODENAME=xenial

cxdiag output:
[MissingLibGsm]
"Level"="Suggest"
"Title"="Missing 32bit libgsm.so.1 library"
"Description"="Lets Windows applications use the GSM codec for audio compression and decompression."

[MissingLibNss_mdns]
"Level"="Require"
"Title"="Missing 32bit libnss_mdns.so.2 library"
"Description"="This library is needed for network and Internet access. Installing it is strongly recommended."

[Properties]
"display.depth"="24"

[Properties]
"opengl.vendor"="X.Org"

[Properties]
"opengl.version"="3.0 Mesa 11.2.0"

[Properties]
"opengl.renderer"="Gallium 0.4 on AMD TAHITI (DRM 2.43.0, LLVM 3.8.0)"

[Properties]
"opengl.glsl_version"="1.30"

Can you try installing the 32bit version of the libnss library?

apt-get install libnss-mdns:i386

And see if that helps?

Caron Wills wrote:

Can you try installing the 32bit version of the libnss library?

apt-get install libnss-mdns:i386

And see if that helps?

Thank you, that solved the problem indeed.

No more error message.

Oliver Nagel wrote:

Thank you, that solved the problem indeed.

No more error message.

Excellent!

Though, this now signifies that there's something strange about our fallback for library detection. I have filed a bug in our tracker. Thank you for bringing this to our attention.

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjoiZW4iLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNzIwODgyNTk1LCJjc3JmX3Rva2VuIjoiMjVBZVcyTTRNcmN4VUZOQSIsImdkcHIiOjB9