CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Installation of windows program hangs

I was trying to install Maxcut software that is not possible to install via wine (it works to a some point then I get error and installation crashes) so there is a good chance it won't work under crossover but still want to make sure if I did anything to make it work.

I am using manjaro so this is a tough one, I know it's not officially supported. This is what I did:

  1. I Downloaded Maxcut install file from their site:
    http://www.maxcutsoftware.com/
  2. Opened crossover and clicked "install microsoft software"
  3. Then I chose "select an installator" and pointed to a file. Also clicked on "update now" before continuing but I doubt it did that (I assume it works that way for windows but not for linux)
  4. Then I selected bootle windows xp, in second try I used win 8
  5. Then choose "unlisted application"
    It shows lacks of some libs with links pointing to a site how to get them. The issue is, when I checked I already had those libs but crossover still claims I don't have them. My suspicion is, that because arch/manjaro are cutting edge, libs are moved to another folder and installer looks in the wrong place.
  6. Installation of maxcut window opens, bar progresses but then it stucks in 1/3 and I can't normally cancel it because cancel button grays out and nothing happens. I might mention that this software needs microsoft net framework 4.

All I can do at this point is cancel installation in crossover window (maxcut installation has to be disabled from system manager forcefully), it shows failed with a log:

http://pastebin.com/SBQZ5LDL

Is anything else I could try? I am completye crossover newbie and would be ready to buy it if it allowed me to run this program in linux. That's the only software that prevents me of using linux at work.

Are the libs you refer to Windows libs? If so, your Linux version should not be the issue. Wne / Crossover are not detecting these libs for some reason. Have you tried to simulate a reboot in Crossover after installing the libs and trying the installation? Good luck!

All the apps that are list are 32bit but your running a 64-bit OS . Right? Have you installed Multiarch support? I think crossover does this but if not try add
32 bit architecture support then update see if the missing 32 bit libraries are there.

Ok i also downloaded Maxcut and tried to install it, it tries to install the .net framework 4.0. Does it do this on you and do you have it installed? I'll download it when i have more bandwidth satellite Internet have to download it in the morning when i have more bandwidth. I'M also running Crossover Linux 15.3 and a Windows 7 bottle i don't think that makes a difference. But you may want to update Crossover if you can.

You must be a follow woodworking Engineer or something. Right? I never knew about maxcut before. I'm trying to get Autocad running in Crossover Linux I'm making good progress at it.

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjoiZW4iLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNzE1NzkzNDc5LCJjc3JmX3Rva2VuIjoiVDlhWFp6U0pjbk1odHdWaCIsImdkcHIiOjB9