CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

I would like to run the Accu-chek app: SmartPix-Software-2.1.0r01-usb.exe

Dear Guys

I am trying to run the app of Accu-chek: SmartPix-Software-2.1.0r01-usb.exe that is an app for transfer the glucose reading from the Accu-Chek Active Glucometer to the Laptop. It is important to me because I am diabetic type II and I use Linux and not Windows. I tried to install using crossover in my Laptop Dell Inspiron 1545 running Debian Jessie 8.5. It seems that the install process was very straightforward and didn't send me any error message. But it didn't created an execution icon in order I could start the app in linux. And I tried to verify the log file in the ending install process but it didn't open. I tried to execute the SmartPix-Software-2.1.0r01-usb.exe using the bottle that it created, but I received a message telling me access Denied. Can someone help me? I bag your pardon for my poor English but my native language is Portuguese. Thanks in advance for any help.

First go to the bottle menu and choose the run command, next at the top of that window choose the bottle that contains the Windows .exe now click browse and select the Windows .exe file, mow on the run command at the bottom left click create launcher.

I remove the bottle SmartPix-Sofotware-2.1.0r01-usb.exe and I re-install crossover (15.3.0-1). I tried to execute again SmartPix-Sofotware-2.1.0r01-usb.exe but it didn't create the exec file in any directory of crossover. When I try to execute SmartPix-Sofotware-2.1.0r01-usb.exe in the home directory, I receive the message 'access denied".

Oi, Antônio! Have you checked the installer file permissions on Linux? Do your user have proper access to read, write and execute? Você tem permissões de leitura, escrita e execução no arquivo de instalação?

Can you see if it's installed in the bottle? check if it's working if it's installed by clicking the exe fire in the bottle. If it is then you'll have to make a launcher for it. But first see if it even installed it.

In the bottle SmartPix-Software-2 I can't see an exe bottom or icon to run. I will try to install it again and show in the email the result of the log file of install.
By the way, how I can to place a figure in this post? When I click in the picture icon, it asks me to place a "Full URL Image". I don't have a home page to place the full url.
Thank you for now.

If you can and the software is up for download send me a link so i can download it and i'll an install it so i can see what it's doing.

Here is the link to the Program I want to run: https://www.debemcomavida.com.br/portal/downloads/SmartPix-Software-2.1.zip
I am trying to create an exe app to run it in my Laptop Dell Inspiron 1545 running Debian Jessie 8.5 Linux. Hope you can help me.
Thank you for now.

I've been working on this for a few minutes the program worked right away for me the only thing it made a desktop launcher and not a menu launcher i found the command for that in ("/home/mike/.cxoffice/SmartPix/desktopdata/cxmenu/Desktop.C^5E3A_users_crossover_Desktop/Accu-Chek+Smart+Pix+Software.lnk" %u)then i created a start menu icon by going to the bottle menu and i clicked run typed ("/home/mike/.cxoffice/SmartPix/desktopdata/cxmenu/Desktop.C^5E3A_users_crossover_Desktop/Accu-Chek+Smart+Pix+Software.lnk" %u) and told it to create a menu launcher.

I'm running Ubuntu 16.04lts 6 bit with multiarch support and Crossover 15.3.1 so my system is somewhat the same as yours. I didn't add anything to my install of this software. The path for you should be about the same just my name would be different. Hope this will help you.

Dear Mike,
Yy install didn't create the path: "/home/nogueira/.cxoffice/SmartPix/desktopdata/...... It looks like it installed very straightforward and don't give me any error message during install. But it didn't create any launcher. I tried to see the log file, but I didn't understand those informations:

***** Fri Oct 7 15:26:29 2016
Starting: '/opt/cxoffice/bin/wine' '--scope' 'private' '--wl-app' 'pluginserver.exe' '--scandlls'

CXConfig->read(/opt/cxoffice/etc/cxoffice.conf)
CXConfig->read(/home/nogueira/.cxoffice/cxoffice.conf)
Product version=15.3.0.29684
5526: Grabbing the '/tmp/.wine-1000/bottle-806-3a0c8f.lock' lock
5526: Got the '/tmp/.wine-1000/bottle-806-3a0c8f.lock' lock
CXConfig->read(/home/nogueira/.cxoffice/SmartPix-Software-2/cxbottle.conf)
Mode = 'private'
Bottle environment variables:
CX_BOTTLE_CREATOR_APPID -> com.codeweavers.unknown
Environment:
CX_ROOT = "/opt/cxoffice"
CX_BOTTLE = "SmartPix-Software-2"
WINEPREFIX = "/home/nogueira/.cxoffice/SmartPix-Software-2"
CX_WINDOWS_VERSION = <undefined>
PATH = "/opt/cxoffice/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/games:/usr/games"
LD_LIBRARY_PATH = "/opt/cxoffice/lib"
WINEDLLPATH = "/opt/cxoffice/lib/wine"
WINEDLLOVERRIDES = <undefined>
LD_PRELOAD = <undefined>
LD_ASSUME_KERNEL = <undefined>
WINELOADER = "/opt/cxoffice/bin/wineloader"
WINESERVER = "/opt/cxoffice/bin/wineserver"
WINEDEBUG = "+cxreboot,-cxassoc,-cxmenu"
CX_LOG = "/home/nogueira/.cxoffice/logs/install_SmartPix-Software-2_5.cxlog.fifo"
CX_DEBUGMSG = "+cxreboot,-cxassoc,-cxmenu"
CX_WINE_USAGE_LOGFILE = "/home/nogueira/.cxoffice/usage.log"
DISPLAY = ":0"
5526: Releasing the '/tmp/.wine-1000/bottle-806-3a0c8f.lock' lock
Command:
/opt/cxoffice/bin/wineloader winewrapper.exe --run -- /opt/cxoffice/lib/wine/pluginserver.exe.so --scandlls

** Fri Oct 7 15:26:29 2016
Starting '/opt/cxoffice/bin/wineloader' 'winewrapper.exe' '--run' '--'
'/opt/cxoffice/lib/wine/pluginserver.exe.so' '--scandlls'

-> rc=0 (took 0.206670999526978 seconds)
'/home/nogueira/.cxoffice/SmartPix-Software-2/cxnsplugin.conf' not modified -> no need to save
:cxlogfilter:exit

I don't know how to find the error and why it is not creating the exe file.

Try going to your bottle in .cxoffice/see if you have a folder named SmartPix see if there's desktopdata just to see if it created those folders if it did your half way there. The program worked great on my ubuntu 16.04 install. I never ask but if your running a 64 bit os if you running a 64 bit you do have multiarch support installed? I only ask because some of the errors doesn't seem right by far.

Dear Mike, it create the following paths:

~/.cxoffice/SmartPix-Software-2/desktopdata/cxnsplugin/linux
and
~/.cxoffice/SmartPix-Software-2/desktopdata/cxnsplugin/linux64

but there is nothing in the end of this paths. They are empty.
There is installed multarch-support also. It is a transition package to multarch compability.
Thank you for now.

1 to 12 of 12

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjoiZW4iLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNzE1NzkzNDc5LCJjc3JmX3Rva2VuIjoidXpnZmtrbWd2R2JyUGZmeCIsImdkcHIiOjB9