CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Crossover 15.0 won't install on Kubuntu 15.10 (Wily) - can't resolve dependencies in any sensible way

Here's what happens trying to install. All packages already on the system are up-to-date. Kubuntu with Plasma 5 etc.

walter@rukbat:~/Downloads$ sudo dpkg -i crossover_15.0.1-1.deb
Selecting previously unselected package crossover:i386.
(Reading database ... 525884 files and directories currently installed.)
Preparing to unpack crossover_15.0.1-1.deb ...
Unpacking crossover:i386 (15.0.1-1) ...
dpkg: dependency problems prevent configuration of crossover:i386:
crossover:i386 depends on libcups2; however:
Package libcups2:i386 is not installed.
crossover:i386 depends on liblcms2-2; however:
crossover:i386 depends on libglu1-mesa; however:
crossover:i386 depends on libxcursor1; however:

dpkg: error processing package crossover:i386 (--install):
dependency problems - leaving unconfigured
Processing triggers for doc-base (0.10.6) ...
Processing 1 added doc-base file...
Registering documents with scrollkeeper...
Errors were encountered while processing:
crossover:i386
walter@rukbat:~/Downloads$

If I try sudo aptitude install to look for the dependences, it first offers a couple of times to fix it by REMOVING crossover, then suggests removing 260-odd packages (including all of KDE, LibreOffice and X server). I gave up after about 10 different scenarios. Needless to say, not going down any of those paths.

Just paid for this, mostly to support you guys rather than any real need (but hoping to improve on Wine experience). But as another thread title said, dead on arrival.

Any suggestions ?

Try use : sudo apt-get install -f

For the past few ubuntu releases, I've had to install the wine package in addition to CO.

Install 32bits libraries

you could also try the generic command-line installer. .

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjoiZW4iLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNzE4NzMyNzMzLCJjc3JmX3Rva2VuIjoiY1JGa1l6UGtGWlJwNnM0QiIsImdkcHIiOjB9