CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Windows based accounting software frees in crossover (for Ubuntu)

Hi everybody.. new to this forum..

I try to install a Windows a windows based 32-bit software accounting software into Crossover on a Linux (Ubuntu 14.04) PC. I use the "unknown application" software settings. It is said to run best under windows 7 and later.

www.persoftpro.se/nedladdning/kassapro.zip

The installation goes without any error messages. But when I open the accounting software the software start a pop-up window for a database registration process. And the pop-up window frees and nothing works.

The support have hinted me that the the accounting software needs access to the windows registry. On a straight question what windows components the accounting software requires the support are clueless.

My best guess is that the the accounting software requires some windows components that is not installed by default in a bottle.

Error log:
Running command: "C:\users\crossover\Start Menu\Programs\KassaPro-KassaLit\KassaPro.lnk"
Bottle: kassapro_60042
Debug channels:

CrossOver Linux 15.2.0
Install location: /opt/cxoffice
64-bit OS
Desktop session: ubuntu
Window manager: Compiz
Locale: sv_SE.UTF-8

Contents of /etc/os-release:
NAME="Ubuntu"
VERSION="14.04.5 LTS, Trusty Tahr"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 14.04.5 LTS"
VERSION_ID="14.04"
HOME_URL="http://www.ubuntu.com/"
SUPPORT_URL="http://help.ubuntu.com/"
BUG_REPORT_URL="http://bugs.launchpad.net/ubuntu/"

cxdiag output:
[MissingLibOsmesa]
"Level"="Suggest"
"Title"="Missing 32bit libOSMesa.so.8 library"
"Description"="This is needed by some games and CAD-like applications to perform off-screen rendering."

[Properties]
"display.depth"="24"

[Properties]
"opengl.vendor"="Intel Open Source Technology Center"

[Properties]
"opengl.version"="3.0 Mesa 10.1.3"

[Properties]
"opengl.renderer"="Mesa DRI Intel(R) Haswell Mobile x86/MMX/SSE2"

[Properties]
"opengl.glsl_version"="1.30"

** Mon Aug 15 17:33:31 2016
Starting '/opt/cxoffice/bin/wineloader' 'winewrapper.exe' '--new-console' '--workdir' 'C:\users\crossover\Start Menu\Programs\KassaPro-KassaLit' '--start' '--'
'C:\users\crossover\Start Menu\Programs\KassaPro-KassaLit\KassaPro.lnk'

***** Mon Aug 15 17:33:31 2016
Starting: '/opt/cxoffice/bin/cxstart' '--bottle' 'kassapro_60042' '--new-console' '--workdir' 'C:\users\crossover\Start Menu\Programs\KassaPro-KassaLit' '--' 'C:\users\crossover\Start Menu\Programs\KassaPro-KassaLit\KassaPro.lnk'

CXConfig->read(/opt/cxoffice/etc/cxoffice.conf)
CXConfig->read(/home/sergeant/.cxoffice/cxoffice.conf)
Product version=15.2.0.29675
5928: Grabbing the '/tmp/.wine-1000/bottle-802-12203e5.lock' lock
5928: Got the '/tmp/.wine-1000/bottle-802-12203e5.lock' lock
CXConfig->read(/home/sergeant/.cxoffice/kassapro_60042/cxbottle.conf)
Mode = 'private'
Bottle environment variables:
CX_BOTTLE_CREATOR_APPID -> com.codeweavers.unknown
Environment:
CX_ROOT = "/opt/cxoffice"
CX_BOTTLE = "kassapro_60042"
WINEPREFIX = "/home/sergeant/.cxoffice/kassapro_60042"
CX_WINDOWS_VERSION = <undefined>
PATH = "/opt/cxoffice/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games"
LD_LIBRARY_PATH = "/opt/cxoffice/lib"
WINEDLLPATH = "/opt/cxoffice/lib/wine"
WINEDLLOVERRIDES = <undefined>
LD_PRELOAD = <undefined>
LD_ASSUME_KERNEL = <undefined>
WINELOADER = "/opt/cxoffice/bin/wineloader"
WINESERVER = "/opt/cxoffice/bin/wineserver"
WINEDEBUG = <undefined>
CX_LOG = "-"
CX_DEBUGMSG = <undefined>
CX_WINE_USAGE_LOGFILE = "/home/sergeant/.cxoffice/usage.log"
DISPLAY = ":0"
5928: Releasing the '/tmp/.wine-1000/bottle-802-12203e5.lock' lock
Command:
/opt/cxoffice/bin/wineloader winewrapper.exe --new-console --workdir C:\users\crossover\Start Menu\Programs\KassaPro-KassaLit --start -- C:\users\crossover\Start Menu\Programs\KassaPro-KassaLit\KassaPro.lnk
fixme:exec:SHELL_execute flags ignored: 0x00000100
fixme:exec:SHELL_execute flags ignored: 0x00004100
fixme:wtsapi:WTSRegisterSessionNotification Stub 0x10074 0x00000000
fixme:wincodecs:JpegDecoder_Frame_CopyPalette (0x4204b1c,0x41a1728): stub
fixme:wincodecs:JpegDecoder_Frame_CopyPalette (0x42d56a4,0x42d5560): stub
fixme:wincodecs:JpegDecoder_Frame_CopyPalette (0x42d56a4,0x42d5560): stub
fixme:dwmapi:DwmSetWindowAttribute (0x1009c, 3, 0x33fd44, 4) stub
fixme:ole:CoInitializeSecurity ((nil),-1,(nil),(nil),4,3,(nil),0,(nil)) - stub!
fixme:mountmgr:harddisk_ioctl The DISK_PARTITION_INFO and DISK_DETECTION_INFO structures will not be filled
fixme:mountmgr:harddisk_ioctl The DISK_PARTITION_INFO and DISK_DETECTION_INFO structures will not be filled
fixme:mountmgr:harddisk_ioctl Unsupported ioctl 2d1400 (device=2d access=0 func=500 method=0)
fixme:dwmapi:DwmEnableBlurBehindWindow 0x4042c 0x33f1d0
fixme:dwmapi:DwmEnableBlurBehindWindow 0x4042c 0x33f31c
fixme:dwmapi:DwmEnableBlurBehindWindow 0x4042c 0x33eddc
fixme:dwmapi:DwmEnableBlurBehindWindow 0x4042c 0x33f5cc
fixme:dwmapi:DwmEnableBlurBehindWindow 0x4042c 0x33f59c
fixme:dwmapi:DwmEnableBlurBehindWindow 0x4042c 0x33f48c
fixme:wtsapi:WTSUnRegisterSessionNotification Stub 0x10074

Seems solved.. a old DOSshell fixed it... at least most of the problems.. are there any other windows component that is missing according to the error log??

Although it seems to work I still have error messages of the same type.

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjoiZW4iLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNzE4NzMyNzMzLCJjc3JmX3Rva2VuIjoiSDZ4aGU5OWFNR2hrN2JRZyIsImdkcHIiOjB9