CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us



CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

No spanish accents in Crossover 12.5.1 and ubuntu 14.04 (MSOffice 2010)
Francisco Huertas Ferrer
Francisco Huertas Ferrer
Posted 2014-06-25 12:18
Hello

I'm using Crossover 12.5.1 and ubuntu 14.04, and I have installed MSOffice 2010.

When I write accents (e.g. é) nothing is written in the text Nothing is nothing (e + ' = no string).

I used Crossover in ubuntu 13.10 and I didn't have problems. but in this versions, (in two different ubuntu installations) I have it.

Which can be the problem?

Thanks

EDIT: My last attempt has been with a empty ubuntu
Silviu Cojocaru
Silviu Cojocaru Omniscient Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate, Rank 8
Posted 2014-06-25 12:21
Does the demo version of CrossOver 13 fix it for you?
Francisco Huertas Ferrer
Francisco Huertas Ferrer
Posted 2014-06-25 12:36
I do not try it because I do not have licence for Crossover 13.

I go to try the demo with Crossover 13
Francisco Huertas Ferrer
Francisco Huertas Ferrer
Posted 2014-06-25 12:43
The problem has not been solved with the version 13.1.3

I have installed the office with a playonlinux and I have the same problem
Silviu Cojocaru
Silviu Cojocaru Omniscient Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate, Rank 8
Posted 2014-06-25 12:51
Hmm so it's probably specific to 14.04. Do those work ok in the native applications like Libreoffice Writer, gedit. etc... ?
Andrew Balfour
Andrew Balfour Advocate
Posted 2014-06-25 13:51
This is a bug we discovered with US International and other foreign keyboard layouts and Ubuntu. We're still working on the issue and there's no fix at this time.
Francisco Huertas Ferrer
Francisco Huertas Ferrer
Posted 2014-06-26 03:21
Ok. I'm waiting for the fix. Until it is fixed I will work with a Virtual Machine (In my work I cannot use Libre Office :()

Thanks you both for the replies
Eduardo Coelho
Eduardo Coelho
Posted 2014-06-26 18:05
Hello,

Try to disable IBUS on system configuration.  Set the default input method from System Settings >> Language Support >> Default input method.

Best regards,
Eduardo COELHO
Francisco Huertas Ferrer
Francisco Huertas Ferrer
Posted 2014-07-04 07:26
Eduardo Coelho Posted:
Hello,

Try to disable IBUS on system configuration.  Set the default input method from System Settings >> Language Support >> Default input method.

Best regards,
Eduardo COELHO


It works for me

A lot of thanks
Caron Wills
Caron Wills
Posted 2014-07-14 13:40
Eduardo Coelho Posted:
Hello,

Try to disable IBUS on system configuration.  Set the default input method from System Settings >> Language Support >> Default input method.

Best regards,
Eduardo COELHO


You, sir, are a genius, thank you! We have added this to our FAQ page regarding Ubuntu 14.04:

 http://www.codeweavers.com/support/wiki/linux/faq/Ubuntu/TrustyTahr#noaccents
Mauricio Henriquez
Mauricio Henriquez
Posted 2014-08-06 12:06
Hi guys,

Same problem here, I'm a registered user of crossover (meaning that I buy it just a couple of months ago) and no accents in my Ubuntu 14.04, all accents works on libreoffice, gedit, etc, so keyboard map is ok but no accents in my MS Office 2010, I do also have installed the spanish support, my system language is english by the way...

I was trying to use the "disable IBUS" fix, but in my System Config >> Language Support >> Keyboard input method system  I just have ·"IBUS" and "none", no "Default input method"....what I'm missing??, what do I need to install to have the "Default input method" option?

Also trying to stop the IBUS deamon the system says that there is no IBUS deamon running...so I'm kind of lost about that...any help?

I also try a number of possible solutions on the web related to add some "WINEPREFIX" or LANG variables to be set to es_ES, but they do not work...

Any news about an official upcoming bug fix from codeweavers?

Thanks!

Eduardo Coelho
Eduardo Coelho
Posted 2014-08-08 14:41
Mauricio Henriquez Posted:
Hi guys,

Same problem here, I'm a registered user of crossover (meaning that I buy it just a couple of months ago) and no accents in my Ubuntu 14.04, all accents works on libreoffice, gedit, etc, so keyboard map is ok but no accents in my MS Office 2010, I do also have installed the spanish support, my system language is english by the way...

I was trying to use the "disable IBUS" fix, but in my System Config >> Language Support >> Keyboard input method system  I just have ·"IBUS" and "none", no "Default input method"....what I'm missing??, what do I need to install to have the "Default input method" option?

Also trying to stop the IBUS deamon the system says that there is no IBUS deamon running...so I'm kind of lost about that...any help?

I also try a number of possible solutions on the web related to add some "WINEPREFIX" or LANG variables to be set to es_ES, but they do not work...

Any news about an official upcoming bug fix from codeweavers?

Thanks!



select none!
Jairo Serrano
Jairo Serrano
Posted 2014-10-30 23:11
Works but...

if i need iBus in others apps like Google Chrome... the special characters don't works!!!!

Bad solution, i recently renew my subscription for another year... please, fix it.
Andrew Balfour
Andrew Balfour Advocate
Posted 2014-10-31 14:05
https://www.codeweavers.com/support/wiki/linux/faq/Ubuntu/TrustyTahr#noaccents has a possible workaround. The issue is with Ubuntu and not Crossover from what the devs tell me.
Bruno Medeiros
Bruno Medeiros
Posted 2014-11-09 17:47
Any official position on this?
If this is a Ubuntu fault, could someone point me de bug report?

As a Crossover customer, I fell A little disapointed with the lack of care with this problem.
J-P Simard
J-P Simard Omniscient Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate, Rank 4
Posted 2014-11-09 18:07
As a French user, on Arch Linux no less, I have all the accents I could ever want. So yeah, it is highly probable that this is a Ubuntu specific problem. If I manage to use my é, è, à, ï, ç, and so forth without issue on one of the most changing distros available, yet use the same Crossover as everybody else, I can only imagine the problem is specific to your distro of choice.

Note that I do understand why you use Ubuntu, but this sort of thousand-papercuts-go-figure-jerkoff problem is exactly why I jumped ship to Arch. The very Ubuntuness that you like so much is also causing you some problems, hidden is some patch or hidden configuration file you'll have trouble finding anything about. I'm not saying you should use Arch, that is entirely up to you, and Ubuntu remains a valid choice by any mesure. My point is that "disappointement" you're feeling might not be directed at the right party.

For what is worth, I'm sure that Codeweavers are definitly trying to correct the issue for their Ubuntu using customers.

EDIT: And would you have bothered to follow the link from Andrew Balfour, the bug report is here: https://bugs.launchpad.net/ubuntu/+source/ibus/+bug/1278569
killerpapy
killerpapy
Posted 2015-03-20 04:36
Hello everybody,

I'm French user and i have the same problem with my fedora 21 (ê, ë, ô...) and Crossover 14.1.0.
Without ibus, it 's working with fedora 20 but not with F21....

Anyone have an idea for my problem ?

Thanks.
J-P Simard
J-P Simard Omniscient Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate, Rank 4
Posted 2015-03-20 06:18
It might not be the same problem, I suggest you open a support ticket instead of reusing an old thread.
Antoine Messiah
Antoine Messiah
Posted 2015-04-08 09:54
It might or might not be the same problem.

I do believe, however, that it is the same problem, as far as it is about creating an accentuated letter with two key strokes, which is the case for the French â ê î ô û ä ë ï ö ü, as it is for the Spanish vowels+accent and the ñ.

I had that issue with CrossOver Linux 13.2.0 running on an Ubuntu-Mate 14.04 OS. Strangely enough, I could not get the accentuated letters (those that need two key strokes) in the main window of the application (Word document, Excel spreadsheet, etc.) BUT I could have them in the popup windows, like the ones you get when you do a "search" or a "search and replace".

For me, this issue was solved by going to "Language support", getting the language support applied to all applications and system-wide, and getting the input method switched from iBus to None. I did not try these 3 actions separately, so I don't know if the "input method" switch is sufficient or not to solve the problem.

Still, this is a bug that needs to be fixed.
Andrew Balfour
Andrew Balfour Advocate
Posted 2015-04-08 12:04
As a heads-up, we're finding the workaround isn't possible on some newer distros and we're trying to resolve this problem once and for all. Hopefully we'll have it fixed in the next update of Crossover.
Caron Wills
Caron Wills
Posted 2015-04-08 15:03
We have recently updated our FAQs and have a workaround section specifically for Fedora 21.

Fedora 21 makes it nearly impossible to turn off ibus. We dedicated a few days to working through issues with this. Hopefully the workaround we have helps you out.

    https://www.codeweavers.com/support/wiki/linux/faq/Fedora#noaccents

If that doesn't help, please open a Support Ticket and ask to be added to bug number 11871.

For reference, our Ubuntu page has also been updated:

    https://www.codeweavers.com/support/wiki/linux/faq/Ubuntu/TrustyTahr#noaccents

It should still work for any Debian based distributions.

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi02LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTcwNTQ3NzcwfQ==