CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us



CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

Dependence problems to install crossover in Debian Jessie 8.7.1
Antonio Carlos Ribeiro Nogueira
Antonio Carlos Ribeiro Nogueira
Posted 2017-04-25 18:39
I am finding problems to install crossover_16.2.0-1 in my Laptop Dell Inspiron 1545 running Debian Jessie 8.7.1 When I give the command "sudo dpkg -i crossover_16.2.0-1.deb" it says me the following messagens:
nogueira@Dell-Tone:~/Downloads$ sudo dpkg -i crossover_16.2.0-1.deb
A seleccionar pacote anteriormente não seleccionado crossover.
(Lendo banco de dados ... 199723 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar crossover_16.2.0-1.deb ...
A descompactar crossover (16.2.0-1) ...
dpkg: problemas com dependências impedem a configuração de crossover:
crossover depende de libc6 (>= 2.11).
crossover depende de libx11-6 | xlibs.
crossover depende de libxext6 | xlibs.
crossover depende de libxi6.
crossover depende de libfreetype6.
crossover depende de libpng12-0 | libpng16-16.
crossover depende de libz1.
crossover depende de libcups2.
crossover depende de liblcms2-2.
crossover depende de libglu1-mesa.
crossover depende de libxcursor1.
crossover depende de libxrandr2.

dpkg: erro ao processar o pacote crossover (--install):
problemas de dependência - deixando desconfigurado
Erros foram encontrados durante o processamento de:
crossover

It says me that libc6 is missing, but I have it installed. libc6-2.19-18+deb8u7
What could I do to solve the problem and istall crossover?
Thanks in advance.
Russell Smith
Posted 2017-04-25 22:17
try sudo apt-get  install -f
Antonio Carlos Ribeiro Nogueira
Antonio Carlos Ribeiro Nogueira
Posted 2017-04-27 20:34
Russel Smith, I already done apt-get install -f but it didn't work, or better, it uninstalled crossover.
Ritesh Raj Sarraf
Posted 2017-10-07 03:32
I have a similar problem with Debian Testing/Sid. And I'm surprised that this is still unresolved. If the .deb packages are such annoyance to a DD to install, I wonder how usual users are dealing with it.
Mike
Mike Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate
Posted 2017-10-09 23:41
Are you running a 64 bit system if you haven't added 32 bit support you'll need to add it.

dpkg --add-architecture i386 && apt-get update

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTM2NjA4NDkzfQ==