CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us



CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

Office365 on Ubuntu 18.04
Marius Mitrofan
Posted 2018-07-02 14:57
I just installed a trial of CrossOver 17.5 today and tried to run Office 365 on my Ubuntu 18.04 (fresh install).

Although the install went just fine and I am able to start and run any Office app (managed to successfully add my Office365 license in Word and write some docs), I'm unable to properly start Outlook.

Initially, it was just failing with "Something went wrong", but after a few restarts it just hangs with "We're getting things ready".

Anyone encountered this before? Should I just drop the trial and not buy the software until full/actual support is provided for Ubuntu 18.04 and/or Office 365?
Jizheng Wan
Posted 2018-07-03 14:28
Same issue here. Any solution?
Anna Lasky
Anna Lasky  Staff Member
Posted 2018-07-04 09:30
Due to the large variation in how different individual Office applications function within the suite, we have listed all of the individual applications and their ratings on the main Office 2016 compatibility page (https://www.codeweavers.com/compatibility/crossover/microsoft-office-2016).  Outlook is currently not running (hence the 2 star rating).  If you are wondering about the typical user experience with other Office applications, that chart should give an indication of whether or not they are expected to work.  

Thanks,
Anna
Radovan Biciste
Posted 2018-11-27 02:48
On Crossover 18 I'm able to run Outlook, Word and Excel. OneNote is complaining about Desktop Experience thing. I installed according to instructions for Office 2016.
Make sure your OpenGL is setup correctly. Was advised by support. Check in Help > System Information. Install 32bit version and all support libraries for OpenGL etc. has to be 32bit too.
Good luck,
Radovan
Angelo
Posted 2019-02-02 06:08
Hi guys,

Sorry put the question here, but its related.

I have O365 installed with crossover and activated, works great. But i want install a language pack and allways give me a critical error.

Any one can tell me how i can install the language package

Thanks in advance
Wade Kappenman
Posted 2019-02-13 16:48
This is sort of related I think? I have Crossover 18.1.0 install under Pop_OS 18.10 and I have been able to install Office365. Excel, Powerpoint, Outlook all see to run but I can't seem to get word working. I will see the loading screen and then it bombs out with and error. "The program WINWORD.exe has encountered a serious problem and needs to close."  Any ideas as to what might be going on?
Hana Pagel
Hana Pagel  Staff Member
Posted 2019-02-13 16:55
Hello Wade,

Did you install Office recently? An update to the Office 365 monthly channel (version 1901) released early this month is causing some problems with Word. We are aware of the issue and working on a fix. If you'd like to receive updates about a solution, please contact our support team.

Hana
Wade Kappenman
Posted 2019-02-13 17:01
Hana Pagel Posted:
Hello Wade,

Did you install Office recently? An update to the Office 365 monthly channel (version 1901) released early this month is causing some problems with Word. We are aware of the issue and working on a fix. If you'd like to receive updates about a solution, please contact our support team.

Hana


Ha! Yes, I installed Office two days ago, so that probably explains my issue. Once the issue is resolved, do fixes like this automatically push out or do they need to be manually downloaded?

Thank you!
Hana Pagel
Hana Pagel  Staff Member
Posted 2019-02-13 17:11
You'll have to manually download - updates to CrossOver Linux can be found here: https://www.codeweavers.com/account/downloads
Wade Kappenman
Posted 2019-02-13 17:21
Hana Pagel Posted:
You'll have to manually download - updates to CrossOver Linux can be found here: https://www.codeweavers.com/account/downloads


Great! Thank you!
Richard Phillips
Richard Phillips
Posted 2019-02-25 12:23
Is there an easy way to rollback updates that doesn't involve having to get on a chat with support? Probably saves everybody a little time.

On an unrelated note: I've been deeply suspicious of Microsoft since the 90's and I feel like they go out of their way to break things that aren't running on their latest and greatest Windows version.
Tom Rigg
Tom Rigg
Posted 2019-03-21 18:35
Hi Hana,

Just to let you know I now have crossover 18.5.0 on my Ubuntu 18.04 installation and the issue mentioned above "The program WINWORD.exe has encountered a serious problem and needs to close." has now gone away.

I can also run Outlook successfully along with Excel, Power Point, Publisher, and Word.

Thanks to you and you team on this one, I have been keeping an eye on a solution to run Office 365 on Linux and this now seems to be the answer. I'll keep testing it over the next few days and all being well I will sign up for a year!

Tom.

Hana Pagel
Hana Pagel  Staff Member
Posted 2019-03-22 10:30
Thank you for the update, Tom! We're excited about the progress we've made with Office 365 and hope you continue to find it a valuable solution.

To Wade and others who have experienced launch failures on recent installations, CrossOver 18.5 supports Office 365 Version 1902, the current monthly channel release.

Since this thread began, we have broadened our support for the Office 365 suite. On CrossOver 18.5, we expect Word, PowerPoint, Excel, Outlook, and OneNote to launch and allow basic use for most Linux users. We encourage users to give CrossOver 18.5 a try on their systems with our two-week free trial: https://www.codeweavers.com/products/crossover-linux/download

Wade Kappenman
Posted 2019-03-22 11:23
This is awesome! Thank you for the progress update on this, Hana! It's exciting to see CrossOver make continued progress with O365. Gives all of us one less reason to need a full windows install.

Keep up the great work!

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTU4MDM0NTA0fQ==