CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us



CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

Microsoft Office 2010 broken after upgrade to Fedora 30
arkanoid
arkanoid Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate
Posted 2019-05-16 02:05
It ran flawlessly on fc28 before, but after the upgrade existing bottles stopped working and that's what I get when I try to install fresh.

I investigated the issue and found that fc30 no longer ships with libcrypt.so.1, the version was bumped to .2, which caused the problem.

Mark Swallow
Mark Swallow
Posted 2019-05-30 21:19
So how did you fix this?
Ryan Abhiram
Ryan Abhiram  Staff Member
Posted 2019-05-31 09:19
Fedora has removed libcrypt.so.1 from the base install. There's a libxcrypt-compat package that should provide this library. Installing libxcrypt-compat fixed the dependency issue with Fedora 30, and Office should work after either re-booting the bottle or re-installing it.

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi02LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTcwNTQ3NzcwfQ==