CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

CrossOver on Steam Deck?

Has anyone tried to install CrossOver (Linux) on Valve's Steam Deck? (If you don't know what this is, look here.) Steam Deck has SteamOS which uses Linux (Arch), so in theory it could support CrossOver. Not sure if the CPU is x86-compatible. If Steam Deck could run CrossOver, that would really open up that device!

Hi Mark,

CrossOver Linux is not supported on the steam deck (the major issue is dependency management).

Best,
Meredith

Thanks, Meredith!

Apparently, Steam Deck has its own Wine app, called Proton. I have no idea how it compares to CrossOver!

Hi Mark,

The CodeWeavers team works with Valve on Proton! We might be biased, but we think it's pretty awesome :)

Meredith

What you could try on the deck is set up an arch chroot environment and install crossover in that. I've had quite a lot of success with many things that wouldn't work on steamos because of dependencies

So I've been trying to install Crossover on a Steam Deck. The main package installed fine, but this dependency is causing an issue. This is what I get in the terminal.

(1)(deck@steamdeck Downloads)$ sudo pacman -Syu gtk3
:: Synchronizing package databases...
jupiter-rel is up to date
holo-rel is up to date
core-rel is up to date
extra-rel is up to date
community-rel is up to date
multilib-rel is up to date
warning: gtk3-1:3.24.34+r156+g812b3930d0-1 is up to date -- reinstalling
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (3) lib32-vulkan-radeon-23.1.0_devel.166660.steamos_3.5.4-1
vulkan-radeon-23.1.0_devel.166660.steamos_3.5.4-1 gtk3-1:3.24.34+r156+g812b3930d0-1

Total Installed Size: 67.87 MiB
Net Upgrade Size: 0.00 MiB

:: Proceed with installation? [Y/n] y
(3/3) checking keys in keyring [########################################] 100%
warning: Public keyring not found; have you run 'pacman-key --init'?
downloading required keys...
error: keyring is not writable
error: required key missing from keyring
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.
(1)(deck@steamdeck Downloads)$ sudo pacman-key --init
gpg: /etc/pacman.d/gnupg/trustdb.gpg: trustdb created
gpg: no ultimately trusted keys found
gpg: starting migration from earlier GnuPG versions
gpg: porting secret keys from '/etc/pacman.d/gnupg/secring.gpg' to gpg-agent
gpg: migration succeeded
==> Generating pacman master key. This may take some time.
gpg: Generating pacman keyring master key...
gpg: directory '/etc/pacman.d/gnupg/openpgp-revocs.d' created
gpg: revocation certificate stored as '/etc/pacman.d/gnupg/openpgp-revocs.d/B22219E24044B314C53F9F2DBCE1F09BD431CD4D.rev'
gpg: Done
==> Updating trust database...
gpg: marginals needed: 3 completes needed: 1 trust model: pgp
gpg: depth: 0 valid: 1 signed: 0 trust: 0-, 0q, 0n, 0m, 0f, 1u
(deck@steamdeck Downloads)$ sudo pacman -Syu gtk3
:: Synchronizing package databases...
jupiter-rel is up to date
holo-rel is up to date
core-rel is up to date
extra-rel is up to date
community-rel is up to date
multilib-rel is up to date
warning: gtk3-1:3.24.34+r156+g812b3930d0-1 is up to date -- reinstalling
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (3) lib32-vulkan-radeon-23.1.0_devel.166660.steamos_3.5.4-1
vulkan-radeon-23.1.0_devel.166660.steamos_3.5.4-1 gtk3-1:3.24.34+r156+g812b3930d0-1

Total Installed Size: 67.87 MiB
Net Upgrade Size: 0.00 MiB

:: Proceed with installation? [Y/n] y
(3/3) checking keys in keyring [########################################] 100%
downloading required keys...
:: Import PGP key 3B94A80E50A477C7, "Jan Alexander Steffens (heftig) heftig@archlinux.org"? [Y/n] y
(3/3) checking package integrity [########################################] 100%
error: gtk3: signature from "Jan Alexander Steffens (heftig) heftig@archlinux.org" is unknown trust
:: File /var/cache/pacman/pkg/gtk3-1:3.24.34+r156+g812b3930d0-1-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]

Does anyone know the purpose of this package and why it might be being read as corrupted?

Well, I know nearly nothing about arch Linux, but it seems that the file is corrupted. That means there was an error when the file was copied (yes, we are in the 21st century, but sometimes a bit in the middle of billions gets wrongly copied. Luckily, checksums exist to make us know that errors). You need to overwrite it with a working copy of it. If you don't know where to obtain a working and trustable copy, you probably need to reinstall your system... Or you could find a friend who owns a Steam Deck and copy the file from his device.

Silvio - thanks for replying. I know the file is corrupted, it literally says that in the terminal. The issue isn't a file already on my SteamDeck (so reinstalling SteamOS won't fix this) it's an external resource Crossover is asking for which a) is coming from an untrustworthy site and b) even if I allow that (which might not be a good idea) it's corrupted anyway. That source is:

error: gtk3: signature from "Jan Alexander Steffens (heftig) heftig@archlinux.org" is unknown trust

Some digging around suggests this person hasn't updated their keys, so maybe not much I can do.

Sorry, now I understood the matter a little better. I believe the installer needs a newer version of gtk3 libs than the official repos provide, so it gets it from an unoffical repo. I've found this, maybe it can help you:

https://bbs.archlinux.org/viewtopic.php?id=233480

Hi Mark,

As mentioned above, CrossOver is not supported on the steam deck for dependency management reasons.

Best,
Meredith

Meredith Johnson wrote:

Hi Mark,

As mentioned above, CrossOver is not supported on the steam deck for dependency management reasons.

Best,
Meredith

Hi - yes I understand, I'm not expecting official support. My main motivation for trying this is I am looking to move from Mac to a Framework Laptop when I get my FW16 later this year, and I'll be running Linux, most likely Debian or a derivative and I wanted to see how well some of my "can't do without" Windows apps will work on Crossover, such as Quicken. Quicken Windows is touch and go and Mac Crossover, I was wondering if it was any better on Linux.

1 to 11 of 11

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjoiZW4iLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNzE4NzMyNzMzLCJjc3JmX3Rva2VuIjoiNjNyYnltdlJNdFd6V0pMeiIsImdkcHIiOjB9