CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us



CrossOver Mac
Discussion about CrossOver Mac

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

Crossover stalls when creating bottle on Mojave
teresa schott
teresa schott
Posted 2019-03-14 10:42
I am running Crossover 18.1 on a new MacBook Pro running Mojave 10.14.3.

When attempting to install applications on a new install of Crossover, the process stalls in the creating bottle stage.  When stalled I see two wine-preloader processes running in Activity Monitor consuming the CPU.  Crossover application becomes unresponsive at this point.  After I force quit Crossover I have to reboot the machine to stop the wine preloader processes.  I've tried two different applications with same result.  I have opened a ticket and followed the suggested instructions to completely repair permissions and completely remove Crossover and reinstall.  After multiple attempts the problem still exists.  I know another colleague has successfully installed the same target application on an older MacBook Pro running the same version of Mojave.

I haven't received any further guidance from the open support ticket so I'm reaching out to the community to see if anyone has experienced similar issues and has ideas.
Mike Norman
Mike Norman
Posted 2019-03-14 16:54
Hi Teresa.

I'm a 2016 MacBook Pro user using Mojave 10.14.3 and also a beta tester.

What model of MacBook Pro do you have and what apps are you trying to install?
I could try the same app on Crossover 18.1 and see if the problem persists in 18.5 beta.

Also, when was the last time you 'spring cleaned' your OS with an app like CleanMyMac?
And when was the last time you restarted or shutdown completely your MacBook?

Hope we can solve your problem soon.

Cheers

--mike

2016 MacBook Pro  |  2.0 GHz Intel Core i5  |  8 GB RAM  |  Intel Iris 540  |  macOS Mojave 10.14.3
Yury German
Yury German Omniscient Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate, Rank 2
Posted 2019-03-14 18:28
I am on 2 separate Mac's and have not had the issues.
I am using USB drive for one and a disk for the other.  One recommendation is that you can move the location on the Mac pretty easily. There is an article on how to do that.

You might want to try an external drive, and see if something is causing an issue.
teresa schott
teresa schott
Posted 2019-03-21 17:01
I'm running a new 2018 MacBook Pro |. 2.7 GHz Intel i7. | 16GB RAM

Still haven't found the solution.  CodeWeavers support believes it is related to some restrictions IT has placed on my machine but without specific information of what folders might need to be temporarily lifted, I won't be able to change those.  

I'm now thinking of moving to a VM solution and giving up on Crossover.
teresa schott
teresa schott
Posted 2019-04-08 11:54
Do your Macs have the new Apple T2 chipset?  Mine does.  I found a somewhat terse comment regarding T2 secure boot features causing problems with emulators like Wine but there were no details.
Mike Lee
Mike Lee
Posted 2019-08-09 14:08
I am installing everything needed. It will not create the bottle.

Cylance is stopping the process on the wine-preloader operation. This is because of a process called StackPiviot.

https://failingsilently.wordpress.com/2018/04/17/what-is-a-stack-pivot/

I have reached out to Cylance and my Cyber team to understand why this is happening. It was not present in previous versions, but can't tell if it's something CodeWeavers has changed or Cylance is now picking up.

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi02LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTcwNTQ3NzcwfQ==