CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us



CrossOver Mac
Discussion about CrossOver Mac

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

WoT Mac Wrapper and macOS 10.15 Catalina - Current Version Does Not Appear To Install and/or Run
Ian Sliwinski
Ian Sliwinski
Posted 2019-06-05 10:28
As macOS 10.15 [Catalina] appears to not allow the current WoT Mac Wrapper to install or run - what are the plans if the production version of the OS drops in September [just a guess based on their past timing]?

Will Wargaming [WG] approve the 64-bit WoT Mac Wrapper that was sent to them by CodeWeavers [CW] last year now?  Understand that there are potential issues as the current native game is a 32-bit app which would require both 32-bit and 64-bit libraries and/or APIs, uses DirectX and the Wine Team needs to find a way to pipe the DirectX calls to Metal as Apple has depreciated OpenGL.

Will we need to wait until Catalina is officially released so that a compatible WoT Mac Wrapper is available?

While I understand that you cannot give detailed information as Catalina is a work-in-progress but some guidance would be appreciated [with the understanding that this is not official and may change at anytime] - e.g. We are aware of the issue and should have a working 64-bit app in several weeks.

Also have you considered a WoT Mac Wrapper Beta Program [WTMWB] in which users sign an NDA and then are given non-production version of the WoT Mac Wrapper.

They would be given a clone of their current account [similar to what happens with Common Test Server] and agree to have detailed debugging information for each game to be sent to CW and WG.  They would agree to not run mods so that the debugging and other data is not influenced by those mods. They would be limited to random battles only as well.  They would be forbidden to disclose that they are part of the WTMWB nor post any information to any public forum as well.
Robert McInnes
Robert McInnes Advocate
Posted 2019-06-09 04:42
CrossOver, and my key application MYOB Accounting 16 are both listed as 64 bit applications [Systems Information, Software, Applications]
Does that mean they will run on macOS 10.15 Catalina?
Ian Sliwinski
Ian Sliwinski
Posted 2019-06-10 14:40
See no reason why not.

However WoT Mac Wrapper is, IIRC, is running a 32-bit version of WINE [1.5.4] and a 32-bit MS Windows XP bottle hence my question.
Robert McInnes
Robert McInnes Advocate
Posted 2019-06-29 08:31
Robert McInnes Posted:
CrossOver, and my key application MYOB Accounting 16 are both listed as 64 bit applications [Systems Information, Software, Applications]
Does that mean they will run on macOS 10.15 Catalina?

Bad news...
I installed macOS Catalina 10.15 Beta (19A487m), and CrossOver does not open...
Previously, I saw near perfect performance of CrossOver running MYOB Accounting 16, on Mojave 10.14.6 - (18G59b).
I am now faced with the option of reverting back to Mojave from Catalina, until this gets sorted...

The puzzle to me is that both Crossover and MYOB Accounting are both listed as 64bit applications in Systems Report, Applications.
32 Bit Applications are listed as (unsupported), so, can someone explain what I am seeing here.

Please, Urgently...

Applications as listed in Systems Report, Applications:
https://www.dropbox.com/s/zn9xv0gyofg8v9e/CrossOver%20Confirmed%20as%2064Bit%20Application.jpg?dl=0
https://www.dropbox.com/s/5g3h1ythka703tf/MYOB%2016%20Confirmed%20as%2064Bit%20Application.jpg?dl=0

Robert McInnes
Robert McInnes Advocate
Posted 2019-06-29 22:08
Ah...
CrossOver appears to be OK, It loads and runs, encouraging me to add another Bottle.
However, if I tap on the "+ MYOB Accounting Plus v16  +" application, on the Internet Explorer "What's new in this Release" document, or the pdf "MYOB Accounting Plus Tutorial", the item will flash, but no response...
Daniel Main
Daniel Main
Posted 2019-07-22 13:35
I get the following error (looking into the logs)
bad CPU type in executable: /Applications/CrossOver.app/Contents/SharedSupport/CrossOver/CrossOver-Hosted Application/wineloader

I just renamed the wineloader file, so that I could use wineloader64
ln -s ./wineloader64 ./wineloader

After this workaround I got the next error:

wine: Bad EXE format for Z:\var\folders\h7\8_yybh112tl37tsmmlnvyjj80000gn\T\htl2u9cl..
winewrapper.exe:error: cannot execute L"Z:\\var\\folders\\h7\\8_yybh112tl37tsmmlnvyjj80000gn\\T\\htl2u9cl /

The specs of my system are:
- MacOS Catalina - 10.15 Beta (19A512f)
- MacBook Pro (15-inch, 2018)
- Crossover Version 18.5 (18.5.0.31742)

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi02LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTcwNTQ3NzcwfQ==