CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Mac
Discussion about CrossOver Mac

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Everquest 2 launcher no longer opens after updating to Ventura 13.4

Hello, I have been running Everquest 2 on an M1 14" Macbook Pro running Ventura 13.1 and CrossOver 22.0.1 and it's been playable without any major issues.

Recently, I needed to reinstall Mac OS and now I'm stuck running Ventura 13.4 and I can't seem to get the launcher to load, it just hangs on the Daybreak logo when I try to launch it and never loads. I have tried using CrossOver 22.0.1 and importing my backup bottle that was working fine and also have tried the latest version of CrossOver and attempted recreating several new Everquest 2 bottles but I can't get it to load anymore.

Is anyone able to help or give me some suggestions to troubleshoot it?

Thanks.

13.3+ requires CrossOver 22.1.1

Hi Patrick,

Looks like you ran into two separate problems here :/ First, as Dean noted, CrossOver 22.1.1 is required for running macOS Ventura 13.3+. Second, it looks like this game had a regression between CrossOver 22 and 22.1. I added a workaround to the CrossTie, so you can try a new installation tomorrow on CrossOver 22.1.1 and it should work.

Best,
Meredith

Hello, thanks for the quick reply.

I tried a few times again this morning, I am using a clean install of Ventura 13.4 with the latest version of CrossOver 12.1.1 but unfortunately I'm experiencing the same issue. I created a new bottle and tried installing Everquest 2 using the installer but once it gets to the point of the installation where the Daybreak launcher loads, it just hangs on the Daybreak logo and never seems to open it. If I cancel the installation at this point and then try opening the Everquest 2 bottle, it just shows the Daybreak logo briefly and disappears, the launcher never seems to open.

Any other ideas?

Thanks.

Patrick wrote:

Hello, thanks for the quick reply.

I tried a few times again this morning, I am using a clean install of Ventura 13.4 with the latest version of CrossOver 12.1.1 but unfortunately I'm experiencing the same issue. I created a new bottle and tried installing Everquest 2 using the installer but once it gets to the point of the installation where the Daybreak launcher loads, it just hangs on the Daybreak logo and never seems to open it. If I cancel the installation at this point and then try opening the Everquest 2 bottle, it just shows the Daybreak logo briefly and disappears, the launcher never seems to open.

Any other ideas?

Thanks.

Yes, you'll need to wait until tomorrow; our CrossTies get refreshed overnight. I saw the same thing you did, and the fix I pushed got me to the log-in screen.

Best,
Meredith

Ah I see, I thought you meant the fix was already live. I'll try again tomorrow, thanks.

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjpudWxsLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNjk1NDAxOTA4LCJjc3JmX3Rva2VuIjoiWTNBNmF5elpuQlF5cnY5ZSIsImdkcHIiOjB9