CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us



CrossOver Mac
Discussion about CrossOver Mac

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

Everquest - Running fine until I bought a license today
Blake Allen
Posted 2017-07-08 11:12
I've had EQ running for roughly a month just fine on my Macbook running El Capatian and crossover 16.2.

Today I bought a license to keep the program running and after applying I can no longer start EQ.  It "starts" as in the application for EQ appears in the hotbar that its beginning to launch but before it ever loads up the launcher the applciation shuts down silently.  Im not sure where to look for logs and console log is not proving to have anything of value.

Additionally, in an effort to work past this, I've tried to install a fresh install of EQ into another bottle and now the installer is failing to work there.  Specifically I am able to install all pre-req's like IE, DirectX, fonts, prior to the EQ launcher itself.  Once it starts installing EQ it gets a small way in then just closes out.  No errors on my screen.  Viewing the install log i see:

***** Sat Jul  8 11:48:03 2017
Starting: '/Applications/CrossOver.app/Contents/SharedSupport/CrossOver/bin/wine' '--bottle' 'EverQuest-2' '--untrusted' '--wait-children' '--no-convert' '--new-console' '--' 'Y:\Downloads\EQ_setup.exe'

CXConfig->read(/Applications/CrossOver.app/Contents/SharedSupport/CrossOver/etc/CrossOver.conf)
CXConfig->read(/Users/ballen/Library/Application Support/CrossOver/CrossOver.conf)
Product version=16.2.0.30219
7515: Grabbing the '/var/folders/5b/ygy77sf95m5683jsmb7z6cch0000gn/T//.wine-501/bottle-1000004-3c0628c.lock' lock
7515: Got the '/var/folders/5b/ygy77sf95m5683jsmb7z6cch0000gn/T//.wine-501/bottle-1000004-3c0628c.lock' lock
CXConfig->read(/Users/ballen/Library/Application Support/CrossOver/Bottles/EverQuest-2/cxbottle.conf)
Mode = 'private'
Bottle environment variables:
 CX_BOTTLE_CREATOR_APPID -> com.codeweavers.c4.24
Environment:
  CX_ROOT = "/Applications/CrossOver.app/Contents/SharedSupport/CrossOver"
  CX_BOTTLE = "EverQuest-2"
  WINEPREFIX = "/Users/ballen/Library/Application Support/CrossOver/Bottles/EverQuest-2"
  CX_WINDOWS_VERSION = <undefined>
  PATH = "/Applications/CrossOver.app/Contents/SharedSupport/CrossOver/bin:/usr/bin:/bin:/usr/sbin:/sbin"
  DYLD_LIBRARY_PATH = "/Applications/CrossOver.app/Contents/SharedSupport/CrossOver/lib"
  WINEDLLPATH = "/Applications/CrossOver.app/Contents/SharedSupport/CrossOver/lib/wine"
  WINEDLLOVERRIDES = <undefined>
  LD_PRELOAD = <undefined>
  LD_ASSUME_KERNEL = <undefined>
  WINELOADER = "/Applications/CrossOver.app/Contents/SharedSupport/CrossOver/bin/wineloader"
  WINESERVER = "/Applications/CrossOver.app/Contents/SharedSupport/CrossOver/bin/wineserver"
  WINEDEBUG = "+cxreboot,-cxassoc,-cxmenu"
  CX_LOG = "/Users/ballen/Library/Logs/CrossOver/Install-EverQuest-2 3.cxlog.fifo"
  CX_DEBUGMSG = "+cxreboot,-cxassoc,-cxmenu"
  CX_WINE_USAGE_LOGFILE = <undefined>
  DISPLAY = ":2"
7515: Releasing the '/var/folders/5b/ygy77sf95m5683jsmb7z6cch0000gn/T//.wine-501/bottle-1000004-3c0628c.lock' lock
Command:
/Applications/CrossOver.app/Contents/SharedSupport/CrossOver/bin/wineloader winewrapper.exe --new-console --wait-children --no-convert --run -- Y:\Downloads\EQ_setup.exe

** Sat Jul  8 11:48:03 2017
Starting '/Applications/CrossOver.app/Contents/SharedSupport/CrossOver/bin/wineloader' 'winewrapper.exe' '--new-console' '--wait-children' '--no-convert' '--run' '--'
'Y:\Downloads\EQ_setup.exe'

fixme:wininet:query_global_option INTERNET_OPTION_CONNECTED_STATE: semi-stub
fixme:sfc:SRSetRestorePointA 0x73f3d0 0xb6e6c4
err:setupapi:do_file_copyW Unsupported style(s) 0x144
err:setupapi:do_file_copyW Unsupported style(s) 0x144
err:setupapi:do_file_copyW Unsupported style(s) 0x144
err:setupapi:do_file_copyW Unsupported style(s) 0x144
err:setupapi:do_file_copyW Unsupported style(s) 0x144
err:setupapi:do_file_copyW Unsupported style(s) 0x144
err:setupapi:do_file_copyW Unsupported style(s) 0x144
err:setupapi:do_file_copyW Unsupported style(s) 0x144
err:setupapi:do_file_copyW Unsupported style(s) 0x144
fixme:wininet:query_global_option INTERNET_OPTION_CONNECTED_STATE: semi-stub
fixme:heap:RtlSetHeapInformation 0x0 1 0x0 0 stub
fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION
err:winediag:wined3d_dll_init CSMT disabled.
fixme:iphlpapi:SendARP (DestIP 0x0101a8c0, SrcIP 0x00000000, pMacAddr 0x334250, PhyAddrLen 0x333f7c): stub
fixme:mountmgr:harddisk_ioctl Unsupported ioctl 74080 (device=7 access=1 func=20 method=0)
fixme:mountmgr:harddisk_ioctl Unsupported ioctl 2d1400 (device=2d access=0 func=500 method=0)
fixme:mountmgr:harddisk_ioctl Unsupported ioctl 74080 (device=7 access=1 func=20 method=0)
err:winediag:wined3d_dll_init CSMT disabled.
fixme:winsock:set_dont_fragment IP_DONTFRAGMENT for IPv4 not supported in this platform
fixme:shell:StopWatchMode () stub!
fixme:shell:SHCreateShellPalette stub
fixme:shell:MLLoadLibraryW (L"browselc.dll",0x75f80000,2) semi-stub!
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:ntdll:EtwEventRegister ({5eec90ab-c022-44b2-a5dd-fd716a222a15}, 0x10001123, 0x100c1630, 0x100c1648) stub.
fixme:ntdll:EtwEventSetInformation (deadbeef, 2, 0x100b4908, 43) stub
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:ntdll:EtwEventUnregister (deadbeef) stub.
fixme:ntdll:EtwEventUnregister (0) stub.
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:ntdll:EtwEventRegister ({5eec90ab-c022-44b2-a5dd-fd716a222a15}, 0x10001123, 0x100c1630, 0x100c1648) stub.
fixme:ntdll:EtwEventSetInformation (deadbeef, 2, 0x100b4908, 43) stub
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported fla

g(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:ver:GetCurrentPackageId (0x2d8f658 0x0): stub
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:shell:MLLoadLibraryW (L"browselc.dll",0x75f80000,2) semi-stub!
fixme:shell:MLLoadLibraryW (L"browselc.dll",0x75f80000,2) semi-stub!
fixme:heap:RtlSetHeapInformation 0x0 1 0x0 0 stub
fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:ntdll:EtwEventRegister ({5eec90ab-c022-44b2-a5dd-fd716a222a15}, 0x10001123, 0x100c1630, 0x100c1648) stub.
fixme:ntdll:EtwEventSetInformation (deadbeef, 2, 0x100b4908, 43) stub
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:ntdll:EtwEventUnregister (deadbeef) stub.
fixme:ntdll:EtwEventUnregister (0) stub.
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:ntdll:EtwEventRegister ({5eec90ab-c022-44b2-a5dd-fd716a222a15}, 0x2eb6f83, 0x5d9a550, 0x5d9a568) stub.
fixme:ntdll:EtwEventSetInformation (deadbeef, 2, 0x5d65a18, 43) stub
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:module:load_library unsupported flag(s) used (flags: 0x00000800)
fixme:ntdll:EtwEventUnregister (deadbeef) stub.
fixme:ntdll:EtwEventUnregister (0) stub.
fixme:ntdll:EtwEventUnregister (deadbeef) stub.
fixme:ntdll:EtwEventUnregister (0) stub.
:cxlogfilter:exit


I've not seen the log for the working install I have, so im not sure if its always logged these bits or what might be wrong here.

Either way I am out $40, and unable to play my game.  Pretty pissed off.

Any ideas?
J-P Simard
J-P Simard Omniscient Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate, Rank 4
Posted 2017-07-08 11:42
Unfortunately, nothing in the install log means much to me...

I do wish to point out two things:

1) You might try a support ticket. This forum is mostly to reach out to the community of users. Codeweavers staff might have a better idea of how to solve this.

2) If EQ is the only reason you bought Crossover, and the problem can't be solved, talk about it to the staff as I'm sure they'll find a way to make things right. They're a pretty understanding bunch.

Good luck running EQ!
Blake Allen
Posted 2017-07-08 14:47
I did also open a support ticket - but being the weekend I assume I wont hear back and I specifically got the license to play on my laptop while im out of town for the weekend.  By monday this will be slightly moot and I'll just be that much more bummed I spent the $40.

Was hoping someone in the community might have seen the same problem and could give me some suggestions on how to proceed while I wait on my support ticket.
J-P Simard
J-P Simard Omniscient Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate, Rank 4
Posted 2017-07-08 14:50
I see...

Have you tried a debug log on your older bottle?

https://www.codeweavers.com/support/wiki/mac/mactutorial/submittechsupportlog

It might have some info otherwise unavailable. You could also do the same thing with the installer in an existing bottle.
Henri Verbeet
Henri Verbeet  Staff Member
Posted 2017-07-08 16:11
Blake Allen Posted:
I did also open a support ticket - but being the weekend I assume I wont hear back and I specifically got the license to play on my laptop while im out of town for the weekend.  By monday this will be slightly moot and I'll just be that much more bummed I spent the $40.

I'm afraid most staff is indeed out for the weekend. I can say we got a number of tickets on this, so we're certainly aware of the issue.

Blake Allen Posted:
Was hoping someone in the community might have seen the same problem and could give me some suggestions on how to proceed while I wait on my support ticket.

For what it's worth, I think https://www.codeweavers.com/support/forums/general/?t=27;mhl=197622;msg=197454 is about the same issue. No fix there either though.
Blake Allen
Posted 2017-07-08 17:20
Henri,

Thanks for the reply, the post you link to matches my issue exactly.  I've added a comment there to also follow along.  Appreciate the pointer in the right direction.

Thanks,

-Blake

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi02LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTQ3NjY2NTQ4fQ==