CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us



CrossOver Mac
Discussion about CrossOver Mac

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

CrossOver stopped launching
William Taylor
William Taylor
Posted 2020-01-26 04:58
Folks

I had CrossOver 19.0.0 running like a champ on Catalina, however it simply stopped launching correctly. I don't mean Windows Apps, I mean CrossOver itself.
On run-up I see the CrossOver menu bar, but everything bar Help is greyed out and no windows appear.

If I run it from the command line I get the message
CrossOver[3604:152096] <class 'bottlequery.NotFoundError'>: There is no bottle named u'default'

Also whenever I try to start CrossOver I see the following in system.log:
CrossOver[3604]: assertion failed: 19C57: libxpc.dylib + 91878 [AC9AD00D-BAA9-3ABC-B557-77E604CF9955]: 0x87


Based on other items in this forum, I have installed Avast AV and Homebrew since CrossOver last worked. I have now removed Avast and reinstalled CrossOver (now 19.0.1).

Any ideas will be greatly appreciated!!

I should point out that I am seasoned in Linux (and Wine and Windows) but relatively new to MacOS, so I haven't got a clue what libxpc is other than presumably a dynamic library. The date on libxpc.dylib is 5 Dec and I am currently on MacOS 10.15.2.

Thanks,
Bill
Ken Thomases
Ken Thomases  Staff Member
Posted 2020-01-27 13:09
Hi Bill,

Can you try the following in Terminal:

cd ~/Library/Application\ Support/CrossOver/Bottles
ls -l


and post the output?

I suspect you have a broken symlink somehow.  CrossOver tracks the default bottle by creating a symlink named "default" that points to the bottle directory.  If the default symlink exists and points to something that no longer exists, you can simply delete the symlink.

I'm not sure what the deal is with libxpc.  XPC is Apple's cross-process communication API.  CrossOver doesn't directly use it, but Apple's frameworks and libraries use it under the hood to communicate with out-of-process services.  For now, let's ignore it and see if fixing the bottle issue gets CrossOver working again.

Cheers,
Ken
William Taylor
William Taylor
Posted 2020-01-28 15:54
Ken

Many thanks - All up and running again now.

The default bottle existed but was empty. I deleted it and restarted CrossOver successfully.

Thanks again

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTk4NTQzNTg1fQ==