CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us



CrossOver Mac
Discussion about CrossOver Mac

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

Fox Go client on Crossover 19.01, OS X 10.15.3
Eskil Varenius
Eskil Varenius
Posted 2020-03-01 06:20
Hello,
I am trying to run the "Fox go client", i.e. a program to play the board game "Go" online on the Fox Weiqi server. The software can be downloaded (english version) via https://www.foxwq.com/soft/foreign.html. Installing in Crossover seems all good, but when trying to run the software I get "The command "/Users/eskil/Library/Application Support/CrossOver/Bottles/FoxGo/drive_c/Program Files (x86)/foxwq/foxwq/foxwq.exe" returned 3." I tried creating a logfile, see below, but unfortunately I am no wiser reading it. Can anyone offer any insight?
Kind regards
Eskil
LOGFILE:
Running command: "/Users/eskil/Library/Application Support/CrossOver/Bottles/FoxGo/drive_c/Program Files (x86)/foxwq/foxwq/foxwq.exe"
Bottle: FoxGo
Debug channels: 

CrossOver 19.0.1.32209
macOS Version 10.15.3 (Build 19D76)
Install location: /Applications/CrossOver.app
Mac Locale: en_SE

CXConfig->read(/Applications/CrossOver.app/Contents/SharedSupport/CrossOver/etc/CrossOver.conf)
CXConfig->read(/Users/eskil/Library/Application Support/CrossOver/CrossOver.conf)
Product version=19.0.1.32209
8179: Grabbing the '/var/folders/1v/s1kt7y3x7gl2vqmgdlzrsjs80000gn/T//.wine-501/bottle-1000005-7b61cd.lock' lock
8179: Got the '/var/folders/1v/s1kt7y3x7gl2vqmgdlzrsjs80000gn/T//.wine-501/bottle-1000005-7b61cd.lock' lock
CXConfig->read(/Users/eskil/Library/Application Support/CrossOver/Bottles/FoxGo/cxbottle.conf)
Mode = 'private'
Bottle environment variables:
 CX_BOTTLE_CREATOR_APPID -> com.codeweavers.unknown
Environment:
  CX_ROOT = "/Applications/CrossOver.app/Contents/SharedSupport/CrossOver"
  CX_BOTTLE = "FoxGo"
  WINEPREFIX = "/Users/eskil/Library/Application Support/CrossOver/Bottles/FoxGo"
  CX_WINDOWS_VERSION = <undefined>
  PATH = "/Applications/CrossOver.app/Contents/SharedSupport/CrossOver/bin:/usr/bin:/bin:/usr/sbin:/sbin"
  DYLD_LIBRARY_PATH = "/Applications/CrossOver.app/Contents/SharedSupport/CrossOver/lib64:/Applications/CrossOver.app/Contents/SharedSupport/CrossOver/lib32on64"
  WINEDLLPATH = "/Applications/CrossOver.app/Contents/SharedSupport/CrossOver/lib32on64/wine"
  WINEDLLOVERRIDES = <undefined>
  LD_PRELOAD = <undefined>
  LD_ASSUME_KERNEL = <undefined>
  WINELOADER = "/Applications/CrossOver.app/Contents/SharedSupport/CrossOver/bin/wineloader32on64"
  WINESERVER = "/Applications/CrossOver.app/Contents/SharedSupport/CrossOver/bin/wineserver"
  WINEDEBUG = <undefined>
  CX_LOG = <undefined>
  CX_DEBUGMSG = <undefined>
  CX_WINE_USAGE_LOGFILE = "/Users/eskil/Library/Application Support/CrossOver/usage.log"
  DISPLAY = "/private/tmp/com.apple.launchd.SaqHgzwx4v/org.macosforge.xquartz:0"
8179: Releasing the '/var/folders/1v/s1kt7y3x7gl2vqmgdlzrsjs80000gn/T//.wine-501/bottle-1000005-7b61cd.lock' lock
Running `"/Applications/CrossOver.app/Contents/SharedSupport/CrossOver/bin/cxavscan" --gui "/Users/eskil/Library/Application Support/CrossOver/Bottles/FoxGo/drive_c/Program Files (x86)/foxwq/foxwq/foxwq.exe"`

** Sun Mar  1 13:10:13 2020
Starting '/Applications/CrossOver.app/Contents/SharedSupport/CrossOver/bin/wineloader32on64' 'winewrapper.exe' '--new-console' '--workdir' '/Users/eskil/Library/Application Support/CrossOver/Bottles/FoxGo/drive_c/Program Files (x86)/foxwq/foxwq' '--start' '--'
'/Users/eskil/Library/Application Support/CrossOver/Bottles/FoxGo/drive_c/Program Files (x86)/foxwq/foxwq/foxwq.exe'

-> rc=768  (took 0.0232760906219482 seconds)
output=[]
Command:
/Applications/CrossOver.app/Contents/SharedSupport/CrossOver/bin/wineloader32on64 winewrapper.exe --new-console --workdir /Users/eskil/Library/Application Support/CrossOver/Bottles/FoxGo/drive_c/Program Files (x86)/foxwq/foxwq --start -- /Users/eskil/Library/Application Support/CrossOver/Bottles/FoxGo/drive_c/Program Files (x86)/foxwq/foxwq/foxwq.exe
000b:fixme:thread:create_user_shared_data_thread Creating user shared data update thread.
000d:fixme:thread:create_user_shared_data_thread Creating user shared data update thread.
0010:fixme:thread:create_user_shared_data_thread Creating user shared data update thread.
0017:fixme:thread:create_user_shared_data_thread Creating user shared data update thread.
001d:err:plugplay:process_IOService_Device object 0x9d03
001d:err:plugplay:process_IOService_Device object 0x9c07
001d:err:plugplay:process_IOService_Device Unable to create plug in interface for USB deviceobject 0x9c0b
001d:err:plugplay:process_IOService_Device Unable to create plug in interface for USB deviceobject 0x9c0f
001d:err:plugplay:process_IOService_Device Unable to create plug in interface for USB deviceobject 0x9c13
001d:err:plugplay:process_IOService_Device Unable to create plug in interface for USB deviceobject 0x9c17
001d:err:plugplay:process_IOService_Device object 0x6c13
001d:err:plugplay:process_IOService_Device object 0x9903
001f:fixme:thread:create_user_shared_data_thread Creating user shared data update thread.
0009:fixme:exec:SHELL_execute flags ignored: 0x00000100
0027:fixme:thread:create_user_shared_data_thread Creating user shared data update thread.
0025:fixme:nls:GetThreadPreferredUILanguages 00000034, 0x209e420, 0x209e490 0x209e428
0025:fixme:nls:get_dummy_preferred_ui_language (0x34 0x209e420 0x209e490 0x209e428) returning a dummy value (current locale)
0025:fixme:heap:RtlSetHeapInformation 0x0 1 0x0 0 stub
0025:fixme:shcore:SetCurrentProcessExplicitAppUserModelID L"Client.AppID.NoVersion": stub
0025:fixme:msvcrt:MSVCRT__set_abort_behavior _WRITE_CALL_REPORTFAULT unhandled
0025:fixme:nls:GetThreadPreferredUILanguages 00000034, 0x209f804, 0x209f874 0x209f80c
0025:fixme:nls:get_dummy_preferred_ui_language (0x34 0x209f804 0x209f874 0x209f80c) returning a dummy value (current locale)
0025:fixme:winsock:set_dont_fragment IP_DONTFRAGMENT for IPv6 not supported in this platform
002e:fixme:thread:create_user_shared_data_thread Creating user shared data update thread.
0025:fixme:shell:InitNetworkAddressControl stub
0025:err:seh:cxx_local_unwind invalid trylevel 0
0025:fixme:msvcrt:__clean_type_info_names_internal (0x566d94c) stub
0025:fixme:msvcrt:__clean_type_info_names_internal (0x2412644) stub
0025:fixme:msvcrt:__clean_type_info_names_internal (0x21ca300) stub
0025:fixme:msvcrt:__clean_type_info_names_internal (0x10026be4) stub
0025:fixme:msvcrt:__clean_type_info_names_internal (0x788b0e54) stub
Eskil Varenius
Eskil Varenius
Posted 2020-09-02 05:22
As I didn't get any replies to this, I contacted support instead. And, I got a great answer! I will post the full answer below, but in short I went to https://www.codeweavers.com/support/wiki/mac/mactutorial/unsupported_deps and downloaded https://www.codeweavers.com/xfer/Dependency_archive/Blank_KitchenSink_Win7.cxarchive . After restoring this bottle, I installed foxwq (fox weiqi / fox go) client inside it. And it worked!

Here's the full support answer, which perhaps can help others googling the same issue:

Thank you for writing us. As it turns out this application is not listed in our support database, this typically means we do not have a reference if this application will install or run in Crossover. We don’t expect all windows applications to work because crossover uses a wine compatibility layer and does not provide a full windows environment. With that being said, I got a different behavior after applying the suggestions outlined in the following link.
https://www.codeweavers.com/support/wiki/mac/mactutorial/unsupported_deps
I used the the bit dependency archive.

If the application installed successfully, you may have to use the "run command" in the bottle.
Browse to the executable that resides in the ProgramFiles> foxwq folder. Select it and run it.
In the run command window click "Save command as launcher" this should create an icon in crossover.
Refer to the following link : https://www.codeweavers.com/support/wiki/mac/mactutorial/run_only

Note, applications being tried in crossover for the first time are not guaranteed to work immediately. If the preliminary steps outlined in the link, adding dependencies and changing configurations do not work, this implies the need for development. With this we don’t have a dev on hand to look into issues with problematic applications. Development resources are limited so we are unable to divert into addressing issues with this particular application.

Regards,
Codeweavers Support

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTk4NTQzNTg1fQ==