CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Mac
Discussion about CrossOver Mac

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

"There is no Windows program configured to run this type of file."

I just finished installing an application and tried to open it , but got an error that reads "There is no Windows program configured to run this type of file." I don't know if that means I should change the configuration of something I already have, or if I should install something new to help it run. The application just appears on my Finder as a .app, and already have DXVK installed. I read through an article about this problem and it said I should install the Microsoft .NET framework, but that hasn't helped.
If it's of any help, I'm running MacOS 11.6 on a 2020 M1 MacBook Air.

1

Not sure if this helps, but are you using a 32 or 64 bit bottle. I hit this error myself and it took me some time before I realised that although the application was 32 bit, the installer and patcher I was using with it had been written in 64 bit. As soon as I created a 64 bit bottle for the application it worked.

How would I be able to do that?

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjoiZW4iLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNzE1NzkzNDc5LCJjc3JmX3Rva2VuIjoiN210azR4YzlmemFwcDZwQiIsImdkcHIiOjB9