CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Mac
Discussion about CrossOver Mac

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Age of Empires IV on Mac

Hi,

Does anybody know how to run AOE 4 on a Mac using CrossOver?

It seems to be discussed here:
https://www.codeweavers.com/compatibility/crossover/forum/age-of-empires-iv/?mhl=248328;msg=247944#msg248328

I also got an error message when i tried it,

Unhandled exception: unimplemented function KERNEL32.dll.GetCurrentPackagePath called in 64-bit code (0x000000007bc2e588).

This specific error seems to be fixed in Wine 6.15 (https://bugs.winehq.org/show_bug.cgi?id=51374) but i don't know if this is picked into CrossOver. Also not sure if this is the only problem.

EDIT: AOE IV is DX12 which is not supported yet, Meredith answered at https://www.codeweavers.com/compatibility/crossover/forum/age-of-empires-iv/?mhl=248328;msg=247944#c3

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjoiZW4iLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNzE1NzkzNDc5LCJjc3JmX3Rva2VuIjoiTUE5UXc2ZDNwRjhhQVJTNSIsImdkcHIiOjB9