CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us



CrossOver Mac
Discussion about CrossOver Mac

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

No more 60 FPS after Yosemite update on latest MacBook Pro Retina
Serge
Serge
Posted 2014-10-31 11:07
I played Quake Live on 13.2 + Mavericks and had 200+ FPS on my latest MacBook Pro 15".

Now on 14.0.1 and Yosemite I see only 60 FPS and no more. Looks like something limit FPS in game.

I noticed that low FPS in every game, so there's problem maybe with new hardware SMS (every system update automatically install new firmware). Some people recommend reset SMS, but I think it's not safe if system will work with old SMS on new Yosemite system.

I think problem with optimization with new firmware and I can't do anything for solve this problem. I have Wine port of Quake Live and get 210-250 FPS in game, but on Crossover no more 60.
Alexander Tornow
Alexander Tornow Omniscient Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate, Rank 2
Posted 2014-11-07 09:09
Hello,

are you sure that you...

- have Vsync (Vertical Sync) disabled in the game? Link

- are running in fullscreen mode?

- have tried disabling/enabling performance enhanced graphics for the Quake Live bottle?

Cheers,
Alex


Josh DuBois
Josh DuBois  Staff Member
Posted 2014-11-07 10:04
Alexander Tornow Posted:
Hello,

- have tried disabling/enabling performance enhanced graphics for the Quake Live bottle?



This would be a particularly useful test if you are getting much higher FPS with wine than you do with CrossOver.  If disabling the Performance Enhanced Graphics does make your FPS go back up, it would be helpful for you to file a support ticket and indicate that someone on the forum asked you to (I can try to monitor responses here as well).  If you need help figuring out where the setting is, please say so here and someone can point you in the right direction.
Serge
Serge
Posted 2014-11-08 14:25
- have Vsync (Vertical Sync) disabled in the game? Link


Disabled.

- are running in fullscreen mode?


Yes

- have tried disabling/enabling performance enhanced graphics for the Quake Live bottle? 


No difference with and without this option.

I see this problem (60 fps limit) also in other virualization systems (Parallels, VMware), so I think it's Yosemite or new MacBook firmware problem. Looks like this restriction is directed to safe temperature.

But there's a mystery for me why independent Wine port run with higher FPS.

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTY4OTgzMzg1fQ==