CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us



CrossOver Mac
Discussion about CrossOver Mac

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

Legacy 8.x - page fault
Tom Stegman
Tom Stegman
Posted 2014-11-02 14:00
I've had CrossOver for a couple years now, and have been using Legacy Family Tree on my Mac without any issues - until now.

I upgraded my Legacy program from 7.5 to 8.0 a few months ago, and today decided to uninstall the leftover installations of Legacy.  I found a Legacy 7.5 uninstaller application, and ran it first.  Legacy 8 would no longer start up.  Thinking that there might now be a file missing, I reinstalled Legacy 8 using the standard install process.  No luck. I removed the bottle, then installed again.  Still receiving error on program launch.  The program starts, goes to the point of selecting which database to open, then halts with the error message below.  Any ideas on fixes?

Unhandled exception: page fault on read access to 0x00000000 in 32-bit code (0x4bb3d02d).
Register dump:
CS:001b SS:0023 DS:0023 ES:0023 FS:1007 GS:000f
EIP:4bb3d02d ESP:00336280 EBP:003362c8 EFLAGS:00010206(  R- --  I   - -P- )
EAX:00000000 EBX:00000000 ECX:4d58c87c EDX:00000000
ESI:80040110 EDI:003362fc
Stack dump:
0x00336280:  00000000 00336300 003362a8 0b92ece8
0x00336290:  00000000 00000000 900cc6d6 9b6cd521
0x003362a0:  00000003 003362d4 00000000 00336330
0x003362b0:  a0a00038 7bc6464e 00336318 0b8ac21c
0x003362c0:  4bb3e317 00336300 00336398 4bb3e3a1
0x003362d0:  0b8ac21c 00336300 003362fc 0b92ece8
0200: sel=1007 base=7ffc0000 limit=00000fff 32-bit rw-
Backtrace:
=>0 0x4bb3d02d in ddrawex (+0xd02d) (0x003362c8)
 1 0x4bb3e3a1 in ddrawex (+0xe3a0) (0x00336398)
 2 0x4bb40f36 in ddrawex (+0x10f35) (0x003363e0)
.
.
.
Nolan Taeksang Yoo
Nolan Taeksang Yoo Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate
Posted 2014-11-03 12:17
ddrawex refers to functions for Direct Draw functions, at least it should. Have you tried installing DirectX Legacy (9.0c)?
Tom Stegman
Tom Stegman
Posted 2014-11-29 18:52
Tried that - no difference.  Tried removing bottle, then starting over, including installing DirectX. No difference.  Reverted back to an install of Legacy 7.5, which works fine (after recovering a backup of the database before upgrading).

Guess for now I will keep using Legacy Family Tree 7.5.

Thanks for your help.
Tom

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi02LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTcwNTQ3NzcwfQ==