CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us



CrossOver Mac
Discussion about CrossOver Mac

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

Could crossover fix it?(WINE has fixed)
user3ds
user3ds
Posted 2014-12-18 04:58
https://bugs.winehq.org/show_bug.cgi?id=34470

AION is still crash with crossover 14.

Thank you.
Silviu Cojocaru
Silviu Cojocaru Omniscient Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate, Rank 8
Posted 2014-12-18 05:11
That bug was marked as closed in wine 1.7.3. Crossover 14 is based on wine 1.7.25 so the bug should be gone. Are you sure that's the reason it's crashing?
user3ds
user3ds
Posted 2014-12-18 06:50
thanks.

I'm sure the reason is msvcp80.
If I remove msvcp80 in libraries, the message become ''can't find DLL''.
If I select native or builtin, the message is ''no access to memory local''
Silviu Cojocaru
Silviu Cojocaru Omniscient Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate, Rank 8
Posted 2014-12-18 07:01
The problem may or may not be in the C++ runtime implementation but is it the same bug? If it's fixed in wine than it's fixed in CX since it's mostly the same code.

Does that application run in wine 1.7.25 and not on CrossOver?
user3ds
user3ds
Posted 2014-12-18 07:41
I didn't test it in WINE 1.7.25 or 1.7.3.
There is only crossover 14 on my mac(YOSEMITE).

I have installed C++2008 in the same winxp bottle.(2005 can't be installed)
Silviu Cojocaru
Silviu Cojocaru Omniscient Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate, Rank 8
Posted 2014-12-18 08:04
So how do you know it's the same bug?
user3ds
user3ds
Posted 2014-12-18 08:21
The error message is as same as blog ''crysystem.dll loading failed no access to memory location''.
And when I removed msvcp80 from crossover's libraries, the error message was changed.
I also tried to remove msvcp90 and keep msvcp80 in libraries, the erroe message didn't be change.
So I think the problem may be msvcp80.
Silviu Cojocaru
Silviu Cojocaru Omniscient Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate, Rank 8
Posted 2014-12-18 08:52
Did you read Piotr's comment? (no. 4)

Posted:

It still doesn't start because of msvcr80 here. I couldn't find what can't be forwarded between msvcr80 and msvcrt. Is there a bug about it? Do you have a list of functions that needs to be fixed?


So, even if it's marked as fixed, they probably did not fix everything. I still don't see any proof that the problem is actually fixed in wine 1.7.3 but somehow re-surfaced in wine 1.7.25 on which CX is based on.
user3ds
user3ds
Posted 2014-12-18 13:54
Thanks.
It has successfully run, but just only one time.
I could login my character, and do everything as same as windows.

When I restart it,crash again.
I didn't change anything, I don't kown why and how.
user3ds
user3ds
Posted 2014-12-18 14:02

just only one time :(

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTY4OTgzMzg1fQ==