CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Mac
Discussion about CrossOver Mac

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Command and Conquer 3: Tiberium Wars on M1

Hello! I'm new to Crossover. I have a 2021 Macbook Pro - so it has a M1 processor - and currently I am trying to get Command & Conquer 3: Tiberium Wars to run.

I have actually been going back and forth on the Youtube comments of a nice guy who made a video about getting this game to run with Crossover on MacOS (though not specifically M1, I don't think). You can see what he suggested and what I tried there:

In short, I tried installing Direct X for Modern Games in my Steam bottle, then installed and ran the game. But it gives me the error: "Please make sure you have DirectX 9.0 or higher installed. Also verify that your video card meets the minimum requirements, and that you do not have hardware acceleration disabled in the Display control panel." It gave me that same error before I tried installing Direct X for Modern Game, by the way.

I did try following some tips from some really old posts on here, but had no luck. I did not keep of every single thing I attempted, but this was one of them, as an example:

Any advice would be much appreciated. Thanks!!

Hi there,

I can't access the link you provide, but I think I know what's going on. We've seen this error with other Command and Conquer games on the new M1 MacBook Pros, and the issue is that the builtin display of the new MBPs does not support the default resolution of the game. Others have reported that using an external monitor worked for them to get around this issue.

We are investigating a solution on our end, but it would be quite involved, so I can't offer a timeline for when we might be able to offer a fix.


If the problem its resolution and you are playing under Steam you could try forcing the resolution:

Steam library
right click on C&C 3
launch options.
type in these "-xres 2560 -yres 1600" without the quotation marks or any other resolution... give it a try.

Thanks so much to both of you for the reply! I will try your suggestion, Israel, sometime today.

Regarding the nice guy's Youtube video on the subject, I'm surprised that's not working but apparently his account just got terminated sometime since my initial post. "This video is no longer available because the YouTube account associated with this video has been terminated." Huh!

Any game that attempts to go fullscreen and use an 800x600 and lower resolution will fail so when possible force a higher will resolve the issue.

As some older gamws simply can’t do this you can workaround the issue by using DxWnd, I’ve used that prior to the later hack (that doesn’t work on the newer M1 systems)

There’s also cncddraw that’s also useful for some titles like C&C RA2/Yuri etc

Hello, I just wanted to chime in that I did get it to work with an external display, so thank you for the suggestion, Meredith! It was not extremely straightforward and a little bit finicky though. I can explain in more detail later.

I tried a few different resolutions using "launch options" as Israel suggested ("-xres 2560 -yres 1600" etc.), but no luck. Behavior was the same as without them.

Thanks to all who chimed in.

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...