CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Mac
Discussion about CrossOver Mac

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Unable to install any software

Hi everybody,
I'm using:

MacBook Air 2020 with M1 chip
macOS Big Sur 11.5.2
CrossOver 21.0.0

Each time I'm trying to install a new bottle (Steam for an instance) it downloads all install files, creates a bottle and fails after that.
When it tries to install first font for it, it opens a window with a question if I accept all terms and conditions for a font, and when I press "Yes", it tells me "The ‘Installing TrueType font: Trebuchet MS’ task failed.". If I press "Try again" after that it fails and says "The '/Users/alina/Library/Application Support/CrossOver/Bottles/Steam/dosdevices/c:/windows/tmpgecrbs73' installation source of TrueType font: Trebuchet MS is neither a file nor a directory!". If I skip all the fonts it fails with Microsoft XML Parser (MSXML) 3.0 install without any reason. And finally it fails the whole installing of the Steam.

It seems like .cxlog file fails with lots of mistakes like this:

wine: Unhandled page fault on read access to 0000000000000000 at address 0000000000483990 (thread 002c), starting debugger...
002c:err:seh:start_debugger Couldn't start debugger L"winedbg --auto 40 44" (2)
Read the Wine Developers Guide on how to set up winedbg or another debugger
003c:err:ole:StdMarshalImpl_MarshalInterface Failed to create ifstub, hr 0x80004002
003c:err:ole:CoMarshalInterface Failed to marshal the interface {6d5140c1-7436-11ce-8034-00aa006009fa}, hr 0x80004002
003c:err:ole:apartment_get_local_server_stream Failed: 0x80004002
-> rc=0 (took 3.0949809551239 seconds)
Running '/Applications/' '--wl32-app' 'rundll32.exe' '--no-quotes' '--scope' 'private' '--winver' 'win7' '--desktop' 'root' '--dll' 'advpack=b;atl=b;oleaut32=b;rpcrt4=b;shdocvw=b;*iexplore.exe=b' 'setupapi.dll,InstallHinfSection' 'win7Install' '128' '/Applications/'

I've tried to use older versions, other bottles (for example Win10), starting macOS in safe mode, creating a new user in the system and installing new CrossOver, deleting CrossOver using CleanMyMac X and nothing worked for me.


Unless you have some anti virus/malware software install I’d look at disabling “ CleanMyMac X” as that lists having an “Malware removal tool” this could be incorrectly flagging CrossOver provided files causing it to remove/quarantine required files breaking CrossOver.

I have the same issue on Apple Silicon M1 Mac mini Big Sur 11.6:

Installing: Microsoft Visual C++ 2010 (10.0) Redistributable (64-bit)
Bottle: Heroic
From download url:

***** Tue Oct 19 20:53:08 2021
Starting: '/Applications/' '--bottle' 'Heroic' '--sync'

***** Tue Oct 19 20:53:08 2021
Starting: '/Applications/' '--scope' 'private' '--no-convert' '--wl-app' 'assocscan.exe' '--scan' '--icon-dir' '/Users/gamerjosh/Library/Application Support/CrossOver/Bottles/Heroic/windata/Associations'

CXConfig->read(/Users/gamerjosh/Library/Application Support/CrossOver/CrossOver.conf)
Product version=
5287: Grabbing the '/var/folders/x/sdfdtf5x0z14rprg04nqbwg00000gp/T//.wine-502/bottle-1000012-2e2799.lock' lock
5287: Got the '/var/folders/x
/sdfdtf5x0z14rprg04nqbwg00000gp/T//.wine-502/bottle-1000012-2e2799.lock' lock
CXConfig->read(/Users/gamerjosh/Library/Application Support/CrossOver/Bottles/Heroic/cxbottle.conf)
Mode = 'private'
CX_ROOT = "/Applications/"
CX_BOTTLE = "Heroic"
WINEPREFIX = "/Users/gamerjosh/Library/Application Support/CrossOver/Bottles/Heroic"
CX_WINDOWS_VERSION = <undefined>
PATH = "/Applications/"
DYLD_LIBRARY_PATH = "/Applications/"
WINEDLLPATH = "/Applications/"
LD_PRELOAD = <undefined>
LD_ASSUME_KERNEL = <undefined>
WINELOADER = "/Applications/"
WINESERVER = "/Applications/"
WINEDEBUG = "+cxreboot,-cxassoc,-cxmenu"
CX_LOG = "/Users/gamerjosh/Library/Logs/CrossOver/Install-Heroic-Microsoft Visual C++ 2010 (10.0) Redistributable (64-bit).cxlog.fifo"
CX_DEBUGMSG = "+cxreboot,-cxassoc,-cxmenu"
DISPLAY = <undefined>
VKD3D_DEBUG = <undefined>
VKD3D_SHADERDEBUG = <undefined>
5287: Releasing the '/var/folders/x
/sdfdtf5x0z14rprg04nqbwg00000gp/T//.wine-502/bottle-1000012-2e2799.lock' lock
CXConfig->read(/Users/gamerjosh/Library/Application Support/CrossOver/CrossOver.conf)
CXConfig->read(/Users/gamerjosh/Library/Application Support/CrossOver/Bottles/Heroic/cxbottle.conf)
/Applications/ winewrapper.exe --no-convert --run -- /Applications/ --scan --icon-dir /Users/gamerjosh/Library/Application Support/CrossOver/Bottles/Heroic/windata/Associations

** Tue Oct 19 20:53:08 2021
Starting '/Applications/' 'winewrapper.exe' '--no-convert' '--run' '--'
'/Applications/' '--scan' '--icon-dir' '/Users/gamerjosh/Library/Application Support/CrossOver/Bottles/Heroic/windata/Associations'

wine: Unhandled page fault on read access to 0000000000000000 at address 0000000000483990 (thread 0044), starting debugger...
0044:err:seh:start_debugger Couldn't start debugger L"winedbg --auto 64 48" (2)
Read the Wine Developers Guide on how to set up winedbg or another debugger

Same for me 😢

Hi folks,

Please look at Dean's comment above and confirm you are not running anti-virus software or CleanMyMac X.



Never, EVER, install antivirus software or malware like CleanMyMac on your Mac.

They hurt much more than they do any good. Well... they don't do anything good at all. I'm posting this as a computer support tech with more than 30 years in the business.


I confirm that I have no antivirus. This happened on my fresh new macbook pro 14 (m1 pro).
Reboots do not solve problem. BUT, I don't know why, today it works perfectly !

Facing the same problem. I cannot even install a 7-zip.

I reset my macbook pro 16 m1 max, with only crossover installed, it still failed to install anything. The tail of the log is here:

** Fri Nov 12 09:50:26 2021
Starting '/Applications/' 'winewrapper.exe' '--wait-children' '--no-convert' '--run' '--'
'Y:\Library\Application Support\CrossOver\installers\a762b6b4a0c132a5f17c54ea2c824fe1.impact32.exe' '/T:C:\windows\tmpgl34d3vk' '/C'

wine: Unhandled page fault on read access to 0000000000000000 at address 0000000000383990 (thread 00d8), starting debugger...
00d8:err:seh:start_debugger Couldn't start debugger L"winedbg --auto 212 48" (2)
Read the Wine Developers Guide on how to set up winedbg or another debugger
003c:err:ole:start_rpcss Failed to open service manager

Besides, version 20.0.4 works but 21.0.0/21.1.0 beta/21.1.0 nightly all not work.

Can confirm.

Fresh-out-of-the-box M1 Air. Installing Steam (or any other app) into a bottle triggers the errors listed by others above.

Edit: just to be sure: I've nothing else installed; no anti-virus, no CleanMyMacX or anything like that. Just plain old vanilla macOS 12.1.

At the moment, I'm not able to use Crossover as no fonts will install.


It's incredible that after months the situation is still unsolved.
M1 Max with version 21.1 and it's completely unusable, since it doesn't let me install any windows software (especially fonts) for the same problem people listed above. I think it's time for a clear explanation, because it is a problem that limits TOTALLY the usage of crossover for some people.


I can only say that CrossOver 21.1 works normaly on my MacBook Air M1 with Monterey. I can install programs just fine and they run... mostly.

So, this seems to be not a simple problem. I would give CodeWeavers time to sort it out. Not sure how high the percentage of affected users is.

Hi folks,

As mentioned in previous comments, these kinds of issues are typically caused by anti-virus software, CleanMyMac X or network issues. If you are using AV or CleanMyMac X, you will need to disable it, remove CrossOver and reinstall. If you are not using AV or CleanMyMac X, then it is a likely a network issue. Private Relay ( on Monterey could be the culprit, so you can try disabling that and seeing if that helps. Router settings could also be the problem, which can be verified by connecting to another network, such as a mobile hot spot.

Lastly, consider this your friendly reminder that these forums are not official support. If my suggestions above don't work, the correct answer (as always) is to submit a support ticket for troubleshooting help.


Same problem when creating bottle with steam or something else..
No antivirus, no private relay.. few days ago all working, today or yesterday crossover start failing with unknown app so i did full reinstall and i get this problem.

** Fri Jan  7 04:07:17 2022
Starting '/Applications/' 'winewrapper.exe' '--wait-children' '--no-convert' '--run' '--'
'Y:\Library\Application Support\CrossOver\installers\9b3124834988748336b51f4cbbb8951f.arialb32.exe' '/T:C:\windows\tmpf5tb5hf1' '/C'

wine: Unhandled page fault on read access to 0000000000000000 at address 0000000000483990 (thread 00e8), starting debugger...
00e8:err:seh:start_debugger Couldn't start debugger L"winedbg --auto 228 48" (2)
Read the Wine Developers Guide on how to set up winedbg or another debugger
00f8:err:ole:start_rpcss Failed to open service manager
00f8:fixme:imm:ImeSetActiveContext (0x8cf70, 0): stub
00f8:fixme:imm:ImmReleaseContext (0000000000020032, 000000000008CF70): stub
00f0:fixme:imm:ImeSetActiveContext (0x16fe58, 1): stub
00f0:fixme:imm:ImmReleaseContext (0004004C, 0016FE58): stub

Try to delete your preference files for CrossOver and then try again.

MEREDITH I don't know how to thank u the real problem is wifi so I took hotspot and it worked so everyone pls try this step

everyone I the real problem is ip address of your wifi so pls take a hotspot and try to install bottle it worked for me i don't know if it legit works for everyone but it may be the real problem so quit crossover join hotspot then launch it again nd install bottle


1 to 17 of 17

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...