CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us



CrossOver Mac
Discussion about CrossOver Mac

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

HELP! Crossover/High Sierra Instal problem?
Timothy Lems
Posted 2017-10-13 08:31
After I updated my mac to High Sierra, Crossover would not shut down and freeze my computer.

I've tried deleting Crossover and reinstalling but it's now giving me the following error.

"CrossOver is unable to initialize a critical component.

Failed to import cxutils module into Python.  See console for errors.

The program will now exit."

Any advice would be greatly appreciated!
Timothy Lems
Posted 2017-10-13 09:03
Solved.

It seems the latest version of Crossover is 16. however when going into my account it only offers me to download 13. which is not compatible.

All the best,
Tim
Bruce W. Hoylman
Posted 2017-11-15 23:35
I have version 16.2.5 installed, and after upgrading to High Sierra I get this error as well. Any suggestions would be greatly appreciated. Thanks in advance.

=bwh=
Claire Normoyle
Posted 2017-11-16 04:07
Hi
This may be an obvious question why is support not helping to solve these issues.  I have the same problem after upgrading and support do not seem to want to help.  I was going to delete and re install but after reading your problems I am not so sure.  Sorry I can't be if more help. I hope we get the problems sorted soon.
Frede Hundewadt
Frede Hundewadt Chief Senior Advocate
Posted 2017-11-16 07:40
Posted:
Failed to import cxutils module into Python.  See console for errors.


macOS has been long time adopting Python 3.6 - you might find the cause of your issue there.

For others

Issues are not persistant and are different from system to system and from your use of CrossOver - if its is private accounting or gaming or ms office or .... I cannot say what or why some fails and others dont.

But I can say that I upgraded my MacBook Pro mid 2017 running Sierra and CrossOver 16.2.5 to High Sierra 10.13.1 with no problems.

My use for CrossOver did not break in any way.
Frede Hundewadt
Frede Hundewadt Chief Senior Advocate
Posted 2017-11-16 07:45
Claire Normoyle Posted:
Hi
This may be an obvious question why is support not helping to solve these issues.  I have the same problem after upgrading and support do not seem to want to help.  I was going to delete and re install but after reading your problems I am not so sure.  Sorry I can't be if more help. I hope we get the problems sorted soon.


It might have slipped you but if you want official support you need to run on the latest crossover and open a ticket.
Bruce W. Hoylman
Posted 2017-11-16 08:35
There are several posts, blogs, and comments surrounding Crossover and this particular error as it pertains to multiple application wrappers. The common thread typically was python and the system installed python vs. an additional python installed by homebrew or perhaps as an active virtual environment. It was the former that I had in my environment. Consequently after cleaning out _all_ of the previous assets and breadcrumbs of Crossover and the applications I had installed within it, reinstalling High Sierra from the App Store,  and making sure any mutable python (homebrew in my case) and not the system python was resolved on my PATH first, I was successful in installing the latest licensed Crossover and the bottles and cans that make up the applications which it wraps.

In short, the approach that worked for me was to clean out the garage completely of all Crossover and related residue and start fresh. By the way reinstalling High Sierra resulted in no data loss for me, but I had backups just the same. It's best to always have a fallback plan there, right?

I hope this gives some direction to others that may be struggling with this issue, as I was. It worked for my situation. Thanks.

=bwh=
Anna Lasky
Anna Lasky  Staff Member
Posted 2018-02-06 12:45
We have just released CrossOver 17.1 for macOS and Linux, which includes a fix for this High Sierra issue.   If you have an active CrossOver 17 license and CrossOver 17 broke with High Sierra, contact info@codeweavers.com and we will upgrade you for FREE.  If you have a license that includes the upgrade, please go here and log in to access the installer, or contact our support team if you need further help.
Charles Fasano
Posted 2018-02-22 22:05
17.1 still does not work on High Sierra for me 10.13.3.  I still get the python error.
-----
This issue has been forwarded to the Official CodeWeavers Ticket System.  If you have observed this issue and would like to report it as well, please open a support ticket or send an email to info@codeweavers.com with a description of what you are seeing and a link to this post.

Thank you!
The CodeWeavers Team
Josh DuBois
Josh DuBois  Staff Member
Posted 2018-02-23 08:17
Charles Fasano Posted:
17.1 still does not work on High Sierra for me 10.13.3.  I still get the python error.
-----
This issue has been forwarded to the Official CodeWeavers Ticket System.  If you have observed this issue and would like to report it as well, please open a support ticket or send an email to info@codeweavers.com with a description of what you are seeing and a link to this post.

Thank you!
The CodeWeavers Team


I forwarded your post to our ticket system.  It sounds like this symptom differs from some which we fixed in High Sierra (python error vs stuck bottles).  Custom (non-system) versions of Python have caused similar trouble in the past.  I've asked our support to reach out and see whether we can figure out what is happening in this case and resolve it.
Hat
Posted 2018-05-03 23:58
Was there a resolution found?

I get the following when I launch

$ /Applications/CrossOver.app/Contents/MacOS/CrossOver
/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.30.2/Common/ChunkCompression.cpp:50: Error: unsupported compressor 8
/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.30.2/Libraries/CompressData/CompressData.c:353: Error: Unknown compression scheme encountered for file '/System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/Exceptions.plist'
/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.30.2/Common/ChunkCompression.cpp:50: Error: unsupported compressor 8
/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.30.2/Libraries/CompressData/CompressData.c:353: Error: Unknown compression scheme encountered for file '/System/Library/CoreServices/CoreTypes.bundle/Contents/Library/AppExceptions.bundle/Exceptions.plist'
ImportError: Bad magic number in /Applications/CrossOver.app/Contents/SharedSupport/CrossOver/lib/python/cxutils.pyc

Then I get the window with

Initialization Failure

CrossOver is unable to initialize a critical component.

Failed to import cxutils module into Python.  See console for errors.

The program will now exit.

Interestingly, when I try to click on the window to copy the text for this post, I then get

/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.30.2/Common/ChunkCompression.cpp:50: Error: unsupported compressor 8
/BuildRoot/Library/Caches/com.apple.xbs/Sources/AppleFSCompression/AppleFSCompression-96.30.2/Libraries/CompressData/CompressData.c:353: Error: Unknown compression scheme encountered for file '/System/Library/Frameworks/AppKit.framework/Resources/Base.lproj/NSTextViewContextMenu.nib'
2018-05-04 00:53:31.273 CrossOver[781:19126] NSSoftLinking - The ShareKit framework's library couldn't be loaded from /System/Library/PrivateFrameworks/ShareKit.framework/Versions/A/ShareKit.
2018-05-04 00:53:55.386 CrossOver[781:19126] NSSoftLinking - The ShareKit framework's library couldn't be loaded from /System/Library/PrivateFrameworks/ShareKit.framework/Versions/A/ShareKit.

$ which python
/usr/bin/python

$ python --version
Python 2.7.10

I think I'm running stock python.  I do use homebrew, but would probably use pythonenv if I needed something specific.

This is a fresh install on this machine - have never run Crossover on it before.  I do have a version of wine that I've had for a bit.

$ wine --version
wine-2.18

Do people have to uninstall the free version wine when they use Crossover?

Thanks!
Anna Lasky
Anna Lasky  Staff Member
Posted 2018-05-04 11:01
You should not have to uninstall wine to use CrossOver.  Some of these issues may be unique to your setup, so I would suggest opening a support ticket using the "Contact Us" link at the top of this page.  

Thanks,
Anna

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTM4NzY3MzM4fQ==