CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us



CrossOver Mac
Discussion about CrossOver Mac

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

Older Versions Of CrossOver
Jack Frillman
Jack Frillman
Posted 2019-06-10 14:28
When I moved to Mojave from Yosemite  my version of CrossOver 16 would not work. So I paid the $40 for the newest version upgraded to CrossOver 18. When I did that one of the application I use CrossOver for didn't work any more. I contacted support and after exchanging a few emails the last I heard from them they suggested going back to the earlier version of CrossOver.   I can't do that because according to their compatibility matrix CrossOver 16 will not work on Mojave.

Has anyone tried running an CrossOver 16 on Mojave?


esank2019
esank2019
Posted 2019-06-10 20:47
CrossOver 16 doesn't run on Mojave.  Which application are you having trouble with?  What kind of issues are you having with the application?
Jack Frillman
Jack Frillman
Posted 2019-07-01 07:06
I found out form Codeweavers support, regardless what the websites says, that it does run on Mojave.  I'm currently running CrossOver 16.2.5 on OSX 10.14.4.
The issue I'm having is Uniden's Sentinel software broke when I upgraded to Crossover 18. Codeweavers support suggested I move back to CW 16 until they can get a fix in.
Pierre
Pierre Omniscient Mystical Exalted Nigh-invincible Supreme Raging Atomic Dragon Turbo Chief Senior Advocate, Rank 8
Posted 2019-07-02 05:05
sometimes, if your program will work on on older version of Cx & on on an older machine,,
- then it would pay to stay with that older version of Cx - indefinitely, if necessary .. ..

thus, you would only Update, only if & when you Updated your machine .. ..

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTcwNTQ3NzcwfQ==