CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Mac
Discussion about CrossOver Mac

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Evaluating CrossOver for Mac (Cannot even launch Notepad.exe)

Hi there --

I'm evaluating CrossOver for Mac and I'm having a really hard time launching something as simple as Notepad.exe. I installed the application and enabled it in my Settings & Privacy settings.

Initially, the wineserver was crashing because of a ulimit error, which I modified to be very high:

❯❯❯ launchctl limit maxfiles
        maxfiles    1048576        2097152

Now I am stuck. I don't know what to do to get this thing to work. The error I get is:

00dc:err:winediag:nodrv_CreateWindow Application tried to create a window, but no driver could be loaded.
00dc:err:winediag:nodrv_CreateWindow L"The explorer process failed to start."

My computer is MacOS Big Sur, 11.7.2, AMD Radeon 580 8gb (which obviously has Metal rendering).

What could be the problem?

Wine works when using wine5.0, but not wine6/wine7.


Hi folks, just wanted to say that I was able to identify and debug the issue. It looks like it was related to fonts (or the font directory?) on my Mac. I was able to debug the issue by using dtruss and it looked like after something w/ font routine (maybe font name enumeration or hard-links [not symlinks] to a dropbox font folder(?) etc.), the dreaded error message "err:winediag:nodrv_CreateWindow" below would appear:

0024:err:winediag:nodrv_CreateWindow Application tried to create a window, but no driver could be loaded.
0024:err:winediag:nodrv_CreateWindow L"The explorer process failed to start.

The below was one of the items that resolved the issue:

  1. Maybe I had too many fonts? (I reduced from 1000 fonts to 300 fonts total)
  2. Maybe some fonts did not load properly?
  3. I remembered I tried to set hard-links instead of soft-links for fonts because Font Book did not load fonts from a soft symlinked directory, so I deleted the font directories that were hard-linked.

I think it's probably the last item. I hope this helps someone else.


Hey Radix! How is going?

I would like to see if you was able to solve your problem. The next time you face some issues with an application, please check the logs and paste it here to see if there is something else triggering this error. I luckily could run all default windows apps right after creating the first bottle without any errors, you might can check the previous logs to see If any other extension failed to load after the install.

Let me know.

Best regards,
Artur Portella.

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...