CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Mac
Discussion about CrossOver Mac

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Xbox Elite Controller 2

Has anyone been able to get an Xbox Elite Controller 2 working under Crossover successfully?

I've done some testing, it appears Crossover specific. The Elite 2 works outside Crossover within MacOS in other games and in Steam for Mac. It shows up in Game Controllers under Crossover but no combination gets anything to register in the controller joystick test or in-game. Hooking up another controller, 8BitDo SN30 Pro, this works flawlessly.

Anyone else had any luck with this particular controller?

Further testing and even a controller update and still no go. Detects but unusable.

I’ve explained this before in other threads, the problem is the version of SDL2 that was available before CrossOver-22.0.0 released had this long standing issue.

Upstream SDL2 only fixed this issue a couple of months back, so unless someone allows a SDL2 bump for CX22.1.0 I don’t see this being officially resolved until CX23.


Hey Travis,

What worked here:
1 - Open the controller settings for the current bottle
2 - Check if there is two detected joysticks, if true, disable the current detected controller (for some reason I had two Xbox controllers there) and leave only one, if not, disable the current controller, reboot the applet and enable it again (and after that reboot the applet again)
3 - Check if the controller is now working in the test joystick's tab

I would mind to check if the controller is detected in the OSx as well.

Let me know if that does help.

Best regards,
Artur Portella

It is Crossover specific for the controller as mentioned in the original post, this works outside Crossover no worries. Issue is the controller is detected fine, but the input doesn't work at all in Crossover, where other controllers do. Specific issue isolated to the controller in Crossover.

Update, replaced SDL2 files from newest version on Github. Still no dice on the Elite Controller 2. Works fine elsewhere, just not in Crossover. Other controllers, 8BitDo for example, work perfectly fine.

TravisLegendZajac wrote:

Update, replaced SDL2 files from newest version on Github. Still no dice on the Elite Controller 2. Works fine elsewhere, just not in Crossover. Other controllers, 8BitDo for example, work perfectly fine.

I got a 8BitDo expecting it to work and running into problems too... has this been resolved? Two "wireless controller"s appear in controller applet, but only one responds in the test window. However when I Override/Disable/Connect they move as a pair... its as though one is bluetooth (doesn't work) and one is wired (does work) but I can't separate the two or get the bluetooth one to work. I can only get the controller to work if I wire up and disable bluetooth. Also even though its responding in the test window, it wont respond in game on Steam. Ideas? I don't know anything about coding so would love more detailed instructions on how to find and replace these SDL2 files if it solved the problem. I'm on Mac M1 Ventura 13.2.1.

Can confirm, Elite Controller 2 now working perfectly on 22.1.0

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...