CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Mac
Discussion about CrossOver Mac

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

App crashes when trying to access USB device

I'm trying to use a windows app that communicates over USB with a serial device. The app crashes a few seconds after launching. The error messages in the log are:

0094:err:plugplay:process_IOService_Device object 0x9c03
0094:err:plugplay:process_IOService_Device object 0x9c07
0094:err:plugplay:process_IOService_Device object 0x9c0b
0094:err:plugplay:process_IOService_Device object 0x9c0f
0094:err:plugplay:process_IOService_Device object 0x9c13
0094:err:plugplay:process_IOService_Device Unable to create plug in interface for USB deviceobject 0x9c17
0094:err:plugplay:process_IOService_Device Unable to create plug in interface for USB deviceobject 0x9c1b
0094:err:plugplay:process_IOService_Device object 0x9c1f
0094:err:plugplay:process_IOService_Device object 0x9c23
0094:err:plugplay:process_IOService_Device object 0x9c27
0024:fixme:exec:SHELL_execute flags ignored: 0x00000100
0024:fixme:exec:SHELL_execute flags ignored: 0x00004100
00ec:fixme:comm:set_queue_size insize 2050 outsize 2050 unimplemented stub
00b0:fixme:imm:ImeSetActiveContext (0x1721d8, 0): stub
00b0:fixme:imm:ImmReleaseContext (00010022, 001721D8): stub
00ec:fixme:imm:ImeSetActiveContext (0x1a7cd8, 1): stub
00ec:fixme:imm:ImmReleaseContext (00010092, 001A7CD8): stub
wine: Assertion failed at address 068B100E (thread 00f8), starting debugger...
00f8:err:seh:start_debugger Couldn't start debugger L"winedbg --auto 232 220" (2)
Read the Wine Developers Guide on how to set up winedbg or another debugger

I followed the instructions on how to set up a new key. Before I did that, the app wouldn't see the USB port. After I installed the key, the app would open and see the USB port but shortly thereafter would crash. Any recommendations how to handle this?

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjpudWxsLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNjczNjM5MzYzLCJjc3JmX3Rva2VuIjoiazhXRTU5UmdVM3dHVWtleCIsImdkcHIiOjB9