CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Mac
Discussion about CrossOver Mac

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Steam games not launching

hello all, I installed crossover and steam on my m1 macbook air yesterday. I downloaded two games to try and their installation is complete. but steam won't launch games. I click start the game, the game closes before it starts in three or four seconds and the start game button appears again. Steam application also freezes mostly, especially on the library page. Directx and core fonts are installed.

Hi there,

What games are you trying to run? It's possible someone here will know of workarounds for specific games.


I have the same problem on MacBook Air M2. It is by Steam, old games like Caesar 3 or Pharaoh. It worked on my previous M1 MacBook in November. (Currently I have no idea if this is HW related or there was some SW change).
Btw. the same is on behaviour is on Porting Kit . Game starts in fullscreen and immediately crash.

World of Tanks works perfect.

Not sure if it will help, but I have had a similar issues sometimes on Borderland the PreSequel. Closing steam, simulating a reboot of the bottle, and re-launching steam usually fixes it. However, this is for a game that typically runs, but sometimes gets stuck in a mode where it won't launch, it may not be the same as your situation.

This is also happening to me. Have crossover installed, Steam installed, and Myst 5 installed but Myst 5 pops up with the wine preloader for a few seconds, I can choose the language I want the game to run in and then it quits.
As a side note, I thought to give crossover full disc access in my security settings just in case it was a security issue. My internet connection is slow, so I haven't tried this on any other larger games, but i did also try it on Commander Keen and same issue, wine preloader opens, I can select which Keen game I want to play, then it just quits.
Mac M1 2020 still running Big Sur

Actually... poking around a bit more, in Steam in Crossover I right clicked Myst 5 and went to Manage- Browse local files & found the .exe for myst 5 and decided to try and launch it from there. Surprisingly it worked, the game launched. However, upon quitting it to come mention this, Steam won't boot up anymore. I've reinstalled it into Crossover, but it doesn't get past logging into my account. Very interesting.

I can't get the problems and solutions reproducible. Sometimes a simulated reboot of steam works to get it to boot again, sometimes the whole computer needs a re-boot to get Steam to open after quitting the games, sometimes the games launch from steam itself, sometimes they will only launch from Manage - browse local files and yet sometimes they don't launch at all with any method. when the games do run, they're slow and clunky despite having a machine that should be more than capable of smooth play. I can't find a common denominator as to why these things are failing. Sad, I thought it would be a good way to enjoy a few games on the M1 and not have to resort to my old and slow vista laptop but alas, I guess not.

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...