CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver ChromeOS
Discussion about CrossOver ChromeOS and Android

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

How to install missing dlls?

I am trying to run a windows program using the Android version for ChromeOS - this program works perfectly with wine in linux, it just needs to mfc40.dll and need to set it to native. I usually just download this with winetricks, then configure it to native and it's good to go.

Is there anyway to do that in this Android application?

Maybe I could take the mfc40.dll from a wine install of it and move it over? I just have no idea how to open the file system and get at the container in this version

Thanks

You can access and change the dlls for a bottle on CrossOver Chrome OS through Wine Configuration. You can access the wine configuration for a particular bottle by clicking on the bottle icon (and if there is more than one application in the bottle, clicking the "Manage" icon) and then clicking the blue down arrow (next to the blue launch button) in the upper right hand corner. This will show the applications in the bottle alongside File Explorer, Command Shell, and Wine Configuration. Open Wine Configuration and switch to the "Libraries" tab to configure the dlls for your bottle.

Thanks,
Anna

Thanks for the prompt reply.

I was ok with that aspect of my issue - I can access winecfg for the program (I guess all programs installed are in their own bottle) of interest. I can add mfc40 as native. BUT - where exactly do I place this missing dll? I can grab it with winetricks in Linux but where do I put it so it'll work? Can I even access the files system to do so? Maybe with an Android root for manager app? The file browser you can access that you referenced only shows the chromeos files, boy Android. Give me some direction

Thanks

The bottles can be accessed through the Chrome OS developer shell, which I think is only available in developer mode. Once you are in developer mode, open a Chrome window and type ctrl+alt+t to open a "terminal" window. Type "shell" to get you into the Chrome OS shell and then "sudo /usr/sbin/android-sh" will get you into the Android shell. From there, the bottles are located at "/data/data/com.codeweavers.cxoffice/files/prefixes." That should get you where you need to be :)

Thanks,
Anna

One of the developers just reminded me that we have an easier way to install certain components into a bottle. The "Install component" feature located in the gear menu right next to the blue launch menu has a large list of components that can be easily installed into the bottle. The particular dll you are interested in seems to be packaged in the "Microsoft Visual C++ 4.0 (4.0) Redistributable" component. Hope one of these solutions works, and if you get your application working we would love to know which one it is!

Thanks,
Anna

Appreciate the ideas

The second one installing the components is the best option as I'm not in developer mode (hence the interest in crossover!).

So I tried to install that component and I get this error "There is no windows program configured to open this type of file". The installation of the component then seems to hang....it just continues without ever closing out. Predictably it doesn't seem like the installation succeeds and I get the same error after putting mfc40 in the winecfg.

Any ideas? Thanks again!

The program is an old very niche neuroscience program called minianalysis for which I haven't really found a better replacement for so would really like it to work on my pixelbook.

I've run across the same error. I'm trying to recall how I got around it. If I recall correctly, I needed to reboot my Chromebook, and start CrossOver afresh, and then, without firing up any apps within CrossOver, go straight to the app. that needs the DLL and follow the procedure using the config. cogwheel once more to install the component which contains the missing DLL. Hope that helps!

  • Mark

It seems like we have at least one bug related to adding components then. I have added the "no windows program configure" error to our bug tracker. Bill, if you are interested in receiving an update if a release of CrossOver Chrome OS is release with a fix for this bug, please feel free to create a support ticket using the "Contact Us" link at the top of the page and requesting to be added to the bug.

Thanks,
Anna

Done. Thanks so much for your help - hopefully it's an easy fix :)

Bill,

there is one more set of things you might want to try. mfc40.dll is supposed to reside in the c:\windows\system32 directory. First of all, on your Chromebook, place your mfc40.dll in the Chrombook's "Downloads" directory. Now fire up CrossOver and click once on the bottle you created for your app., and then click on that same icon once again, and you'll get to the configuration screen. From there, use the drop down menu next to the cog wheel to select "Launch File Explorer." This will fire up your CrossOver Windows environment (bottle) and run file explorer in it. From there, use your mouse to go to the Start Menu and select "Run..." and type in "CMD" (without the quotes of course, as for all commands I'll be writing about) which will fire up a command window. Now type in "cd c:\windows\system32" and that will place you in the correct directory. Now type in "copy y:\mfc40.dll" That should copy the dll to the proper location in your Windows environment. You may also want to try to register the dll by typing in "regsvr32 mfc40.dll" to register your dll in the Windows environment. You can now type "exit" in the command window, which will close it out. Now you can close out File Explorer by clicking the "X" in the upper right corner. This will take you back to the config screen. From here, use the drop down again to select your app. This will fire up your app with the updated environment containing the mfc40.dll and perhaps it will work now. I hope that helps...

  • Mark

Hi again Mark. I have tried to register a missing DLL but I am getting errors from regsvr32. Other forums have suugested that this an error caused by an old version of winetricks; I can find anything on how to update that from within the Chrome emulator. Any ideas?

Thanks.

Michele

Sorry Michele,

not that I am aware of. Winetricks is something that folks are clamoring for in the Chrome environment, but I haven't seen a good solution yet (I believe I read about some people getting it to work via Linux which is underneath Chrome OS, but that required a lot of messing around, even perhaps rooting the Android environment, which I have done before, but found that it was just not worth all of the trouble). You can read about Josh DuBois' exploits in trying to get Winetricks to work with Wine for Android here, I found it a bit informative if nothing else. Be careful if you decide to put your Chromebook into Developer Mode as it will wipe all of your files and data.

Thanks. My linux experience would fit in a teaspoon, so things would get interesting. I've already switched to developer mode - with the powerwash - and things are shiny and new again.

Michele

Good for you!

I actually mis-typed, I am still in Developer Mode, just not on the Beta Channel, which I would not recommend. Being on the Beta Channel is what was causing me to have issues periodically, so I switched back to the Stable Channel and no issues since.

1 to 14 of 14

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjoiZW4iLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNzE4NzMyNzMzLCJjc3JmX3Rva2VuIjoiTGd6dzhzbm40cmV6S055VyIsImdkcHIiOjB9