CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us



CrossOver Chrome OS
Discussion about CrossOver Chrome OS and Android

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

Where can I find files from Crossover?
Brian Cahoon
Posted 2018-12-09 16:21
I finally got Dwarf Fortress installed. Its the latest version, so thank you so much for that! My only issue now, is I want to install a mod for the game, to change the Ascii graphics so to speak. I need to find where Crossover installed Dwarf Fortress on my Chromebook, so I can put the mod files in there. I cannot to find the Dwarf Fortress folder ANYWHERE on my Chromebook.Can anyone help me out please?
Mark Davis
Mark Davis Chief Senior Advocate
Posted 2018-12-10 09:56
Hey Brian,

glad you got it working!  Again, not being familiar with the game, I can only give you some suggestions based on the little I know about CrossOver.  If you downloaded DF from a zip and unzipped it, it probably lives on your Y: drive, which should be the Downloads folder on your Chromebook.  If you used an installer, then it should be on your C: drive under "Program Files" and then under whatever directory DF installs itself.  You can use the method I described before to fire up File Explorer, and it defaults to the Downloads directory where you can search for DF, or you can type C: into the "Location" in File Explorer and hit enter which will take you to your C: drive in CrossOver.  From there you can double click on "Program Files" and see if you find the DF files in there somewhere.  Hope this helps...
Brian Cahoon
Posted 2018-12-11 14:21
Well Mark, here is the thing. I'm so close I can taste it. but for some reason these things just arent working right lol. I followed your advice. Let me tell you what I did and what happened and maybe you can know what I'm experiencing.
 First I installed dwarf Fortress via Crossover. It works. But I have a mod that will make the graphics much easier on the eyes. That  mod is a folder of files in a rar file. So I unpacked the mod folder to my Chromebooks download folder. The mod is actually the Dwarf Fortress game already modded and ready to play. All you do is start the game by clicking the DF.exe in the game folder. The game has no installer, not even from the games website. Know what I mean?
 So I open up Total Commander and navigate to the c:\program files directory. I see the Dwarf Fortress folder that Crossover installed. I just need to delete that folder and put in the modded one from my Y:\downloads folder. I copy and paste it from Y:\downloads to C:\program files. Using Total Commander, I can now see C:\program files\Dwarf Fortress. But when I try to start the game via Crossover it gives me an error saying file not found, and then a second error saying "there is no windows file configured to open this type of file".
 The really weird thing is when I look in Total Commander, I can now see C:\program file\Dwarf Fortress folder with all the game files in it. But if I open File Explorer in Crossover, when I go to C:\Program files, there is no Dwarf Fortress  folder in it.
 I dont understand any of this lol. How can it be there in one program but not the other? Or why the game wont start after I swap the original DF folder for the modded one. Im just at a loss.
Mark Davis
Mark Davis Chief Senior Advocate
Posted 2018-12-12 22:26
OK Brian,,

that is weird!  I wish I had an explanation for that behavior!  So when you successfully rename directories and have the modded version of DF in place, you can't double click on its .EXE file and run it without that error message?  I've only seen that with things like .CAB files or .MSU and sometimes .MSI files, but never .EXE files.  I'm sorry to say that this issue is beyond me.  Hopefully one of the Codeweavers folks will be able to help you further.

I suppose as a final suggestion, you may want to try using TC to rename the DF executable not to contain a space and try double clicking it then and/or running it from a CMD prompt.  I've had similar errors/issues with file names with spaces in their name...
Brian Cahoon
Posted 2018-12-13 15:51
Yea thats just the thing. When I click on the exe in the game folder it says the same error as I said above this post. On the other hand, I tried to do all this with a different game, a visual novel game, and it starts just fine clicking on the exe. I have one more idea to try. Hopefully it works. Either way man, thanks so much for all your help. I really appreciate it.
Mark Davis
Mark Davis Chief Senior Advocate
Posted 2018-12-13 19:00
Sorry Brian,

wish I could be of more help.  I'd give the rename a shot, just in case the space in the name is the issue.  I hope you can get it working...

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTU4MDM0NTA0fQ==