CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Chrome OS
Discussion about CrossOver Chrome OS and Android

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

**NEED HELP WITH CROSSOVER APK**
I've managed to enter my Chromebook into developer mode and enable "unknown sources".... I download the newest version of the CrossOver apk and during the installation process, it pops up with a message that my device is not compatible. Is there any other option for me?? Thanks
CrossOver Chrome OS requires a Chromebook with an Intel processor and Android version 5 or later is my understanding.  Do you know if your Chromebook meets those requirements?  If it does, what version of the APK are you installing?  APKMirror seems to only list v18.0.0 whereas the Play Store shows v18.1.0 as the latest.  I've seen other APK sites that appear to carry v18.1.0 if that helps any ...

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjpudWxsLCJjYXJ0IjowLCJ0enMiOi02LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNjM4Mzc3ODkzLCJjc3JmX3Rva2VuIjoiWjJtc3RYdG5kbW15SlB3OCIsImdkcHIiOjB9