CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Chrome OS
Discussion about CrossOver Chrome OS and Android

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

failed to install missing packages
I have tried to install a unlisted application and i get error messages like lib64 and stuff and i try to install the packages and they failed.
the other forums suggest i check system requirements, which i meet all of and it doesnt work.

Please help me, Thank you
Hi there,

If you run "sudo dpkg --add-architecture i386"  (without the quotes) in the terminal before attempting to install an application in CrossOver, does that go any better?

Best,
Meredith
I'm testing this on a brand new Chromebook (Intel Celeron).  When I try to create a 32-bit bottle, it fails with "failed to install missing packages".
(Note: I had run the "sudo dpkg --add-architecture i386" command in Terminal earlier.)

It mentioned that "libfreetype6:i386" is one of the missing packages.  I tried to install that package in Terminal, but it said "unable to locate package".  Here's my Terminal session:

troywolbrink@penguin:~$ sudo dpkg --add-architecture i386
troywolbrink@penguin:~$ sudo apt-get install libfreetype6:i386
Reading package lists... Done
Building dependency tree      
Reading state information... Done
E: Unable to locate package libfreetype6:i386
troywolbrink@penguin:~$

Any ideas on how to fix this?

Thanks,
Troy
Hi folks,

Sorry about that; you also need to run "sudo apt update" after running "sudo dpkg --add-architecture i386." If that doesn't work better, let me know.

Best,
Meredith
Hi Meredith,

Thanks!  Running these two command did the job:

sudo dpkg --add-architecture i386
sudo apt update


I was able to install my application (TntConnect) and it ran great on my Chromebook!

--Troy
Awesome; so happy to hear that Troy!

Best,
Meredith
I deleted my Linux environment and created a new one to start from scratch.  I installed CrossOver 21.1 without any additional commands.  So this is was a big step forward.  The only problem I run into is when I try to register CrossOver.  After I type in my CodeWeavers email/password and hit Enter, it says "Registration Failed".  A terminal window appears that says:

#
# Type the root password
#
This operation must be run as root:

  /opt/cxoffice/bin/cxregister --install /tmp/license.txthp3ye5mi /tmp/license.sig7yd3uwxz

Trying with pkexec...
cxregister:error: [Errno 2] No such file or directory: '/tmp/license.txthp3ye5mi'
Finished. Press Return to continue.

--Troy
Hi Troy,

Can you try registering from the command line and see if that makes a difference. Open a terminal and run the following command, then enter your user name and password.

sudo -H /opt/cxoffice/bin/cxregister

If that doesn't work, please open a support ticket.

Best,
Meredith

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjpudWxsLCJjYXJ0IjowLCJ0enMiOi02LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNjM4Mzc3ODkzLCJjc3JmX3Rva2VuIjoiZEp0V3RNc2d5eHlYdHRDdSIsImdkcHIiOjB9