CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver ChromeOS
Discussion about CrossOver ChromeOS and Android

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

unmet dependencies question

when trying to install crossover on my chromebook(c330) this is the following i receive
"The following packages have unmet dependencies:
crossover:
Depends: libc6 (>= 2.23) but it is not installable
Depends: libc6-i386 (>= 2.23) but it is not installable
Depends: perl but it is not installable
Depends: python3 but it is not installable
Depends: python3-gi but it is not installable
Depends: python3-dbus but it is not installable
Depends: gir1.2-gtk-3.0 but it is not installable
Depends: gir1.2-gdkpixbuf-2.0 but it is not installable
Depends: gir1.2-pango-1.0 but it is not installable
Depends: gir1.2-glib-2.0 but it is not installable
Depends: gir1.2-vte-2.91 but it is not installable"

if anyone has any words of advice its welcomed. cheers

2

I can confirm I'm having the same issue, and are still finding a workaround.

I am having the same issues. Hopefully someone has a fix

Hi folks,

The Linux environment on ChromeOS has changed to a newer Debian version, and now Crossover does not install seamlessly like it used to. We are working on a fix for our next CrossOver release.

In the meantime, you can open a terminal and run "sudo apt update" followed by "sudo apt upgrade" in your Linux partition. After running those and then rebooting, CrossOver should install (as long as you are using an Intel Chromebook).

Best,
Meredith

1

Thank you it helped.

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjoiZW4iLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNzA4NjEzODE4LCJjc3JmX3Rva2VuIjoiWlZNelk1ZWRFeHVCZlhBWSIsImdkcHIiOjB9