Community Forums - Unsupported Builds

Important Information These are community forums and not official technical support. If you need official support: Contact Us



Unsupported Build General Discussion
Comments and Questions about Unsupported Builds.
*NOTE* These builds are unsupported, do not expect full technical support in this forum.

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

Install error
jfnvf378
Posted 2010-10-11 18:25
I get the following install error on FreeBSD 8.1-STABLE amd64 host:

/libexec/ld-elf.so.1: Shared object "libXi.so.6" not found, required by ".setup13075"
The setup program seems to have failed on FreeBSD / x86 / unknown.
Check the system requirements at:
http://www.codeweavers.com/products/cxoffice/requirements/

You might be missing the 32bit compatibility libraries.


The kernel is compiled with:
options         COMPAT_FREEBSD32        # Compatible with i386 binaries


Is this what the error is referring to or something else?

Thanks
-James
Artist Formally Known as Dot
Artist Formally Known as Dot Advocate
Posted 2010-10-11 18:56
Hi,

 No, it is referring to a 32bit build of libXi.so.6 not your kernel build.
The libXi.so.6 file would be part of Xfree/Xorg...

Cheers!
jfnvf378
Posted 2010-10-13 12:36
Thanks, I got around it by downloading the 32bit pkg and unzipping it into /usr/local/lib32

Had the same error for zlib so I made a soft link to the newer version make world had installed under /usr/lib32 and that seemed to work.

Now I'm getting the same error for libxcb, and I've taken the same steps to resolve, however it seems to be looking in the wrong place.

/libexec/ld-elf.so.1: /usr/local/lib/libxcb.so.2: unsupported file layout

probably some ldconfig problem, I'll post if I figure it out.

Thanks again.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi02LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTE3NTAzNDk0fQ==