Community Forums - Unsupported Builds

Important Information These are community forums and not official technical support. If you need official support: Contact Us



OpenSolaris Build
This forum is a place to discuss issues with OpenSolaris builds.

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

Is it possible to register the Solaris build?
Rudy Grigar
Rudy Grigar
Posted 2010-02-28 14:57
I have a purchased copy of Crossover linux professional, and have been playing around with the opensolaris build on my desktop.  So far it's working great and I am very pleased with it.  When I try and register the software (which I have to launch from the terminal using 'pfexec /opt/cxoffice/bin/cxregister') the process looks like it's working- I'm able to get as far as validating my account but the registration stops at this point saying it's unable to validate my credentials.

I've checked and the user/pass I'm using is correct.  Has anyone successfully registered this build?  Is it possible?

Thanks,
Rudy
Artist Formally Known as Dot
Artist Formally Known as Dot Advocate
Posted 2010-02-28 15:50
Hi,

  I don't know for sure, but it wouldn't surprize me if an unsupported
build in also unregisterable...ie; if it could be registered, that it itself
would be offering support that unsupported builds don't qualify for...(?)..
something like that....if this post goes (officially) unanswered, you could
also ask this question via   info@codeweavers.com   and they'll let you
known for sure...

Cheers!
Darik Horn
Darik Horn
Posted 2010-05-08 23:42
I also have a Solaris build that has expired.  The cxregister program downloads the "unlockable bottle" and complains about my username and password before failing.

Can one of the CodeWeavers staffers enable my account for Solaris or otherwise provide a regular package?  -- Based on some earlier forum postings, it looks like Andrew Bogget has this super power.

I'm running CrossOver 8.0 on OpenSolaris snv_134, which still works well enough for Internet Explorer 6 and WinRAR.
Andrew Bogott
Andrew Bogott
Posted 2010-05-17 14:45
Hey all --

   I just spent some time on this and it turns out that fixing demo registration in the 8.0 Solaris builds is pretty hard.  Instead we've just replaced the time-limited builds with fully enabled builds -- a quick reinstall should get you there.

   We hope to have 9.x builds for Solaris someday, but we still need to figure out what to do about the new Python and pygtk dependencies.

-Andrew
Darik Horn
Darik Horn
Posted 2010-05-21 22:18
The unlocked build for Solaris works well.  Thanks, and much appreciated.

This forum is indeed powerful; I summoned you with an incorrect spelling of your name.  ;)
lidun
lidun
Posted 2010-05-22 23:31
//lidun1977@gmail.com" target="_blank"> 😅 [code][/code][code]
R Fujii
Posted 2010-08-17 14:46
Ok.... using the 9.1 builds, it still fails in registration.  I don't know if the 9.1 build is time limited or not, but it would be nice to get the Buy Now/Register/Register Later/Exit dialog to go away....
Andrew Bogott
Andrew Bogott
Posted 2010-08-19 11:00
Thanks for the nudge!  I've set up the key files for Solaris and BSD builds, so you should be able to unlock now.
R Fujii
Posted 2010-08-23 21:33
Thanks.  The registration works and it doesn't come up with the nag screen.  Though I wish one could at least log bugs against this (I know it's unsupported, but a problem is a problem).   The most serious of which is file dialog seizes when you move up to the root directory.
R Fujii
Posted 2011-01-28 13:24
Well, I'm thankful that you guys made a 10.0 build for solaris.... but registration seems busted again....
Jeremy White
Jeremy White  Staff Member
Posted 2011-02-01 15:23
R Fujii Posted:
Well, I'm thankful that you guys made a 10.0 build for solaris.... but registration seems busted again....


Whoops, sorry.  Can you try now?  I think I fixed it...
W. E. Knox
W. E. Knox
Posted 2011-02-01 20:31
hey look, I'm not really trying to "fix" something that isn't broken but what do you mean you can't support an "unsupported build"?  You've been very responsive to my problems with an opensolaris build as well as, it appears, other peoples'.  Crap, I wouldn't even bother to call Microsoft or, yikes, Oracle for my opensolaris problems and they offer "support."

How far can we push you guys?  Your "unsupported" builds have better support than those other guys' "supported" stuff.  My 10.0.0 build is working great now.  What would we have to do to get support?

gratefully,

walter
Jeremy White
Jeremy White  Staff Member
Posted 2011-02-02 10:18
Thanks for the kind words; it's much appreciated.

But unsupported means we feel no obligation to help in any way.  We often go months without looking over here, and it may not have been visible here, but we messed up on 9.2 pretty badly.

As an example of what unsupported means - we didn't test this Solaris build *at all*.  That is, we do Solaris for a large customer of ours, and we tested this stuff in that context and in their environment.  But the 'consumer' version of CrossOver requires python and gtk, and our 'stock' Solaris test systems don't have working versions.  So we shipped this without running it once.  Apparently we got lucky, and it worked 😊.

To get *real* support, you'd either need to be a large customer of ours, or generate a huge groundswell of popular support.  You can see in this thread:

FreeBSD forum thread

that that approach has pretty much failed.  To date, we have evidence of no more than about $1,280 for all the work we've done on this.

Cheers,

Jeremy
he.susan139@gmail.com
Posted 2011-03-23 22:14

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTI1ODk4MDg2fQ==