Ubuntu 12.04 - Precise Pangolin, Mint 13 - Maya, ElementaryOS

This article is provided to serve as additional support for those people running Ubuntu 12.04, Linux Mint 13, ElementaryOS, and any derivatives based on them. It was created with help from our diverse Linux community. Many thanks to them!

If you are installing CrossOver for the first time in Ubuntu 12.04 or a derivative based on that version, you are in the right place but skip to installation.

If you are running a Debian or Ubuntu based derivative and receive the error:

   Dependency is not satisfiable: dpkg (>= 1.16.5)

You are in the right place. You have likely received this error because you're trying to install CrossOver 12.5.1 or later via the debian based installer. Unfortunately, this will not work.

If you would like to update CrossOver, you will need to download the .bin installer instead. Before doing so, please completely remove the debian installer from your system.

If you want to keep the applications you've already installed in CrossOver, please archive your bottles before starting this procedure.

First run:

Then run:
sudo /opt/cxoffice/bin/cxuninstall

If CrossOver was installed with the Ubuntu Software Center, the place-holder that method leaves behind will need to be removed.

for 32bit:
sudo apt-get remove crossover-trial-bin

for 64bit:
sudo apt-get remove crossover-trial-bin:i386

And, if the terminal gave this or similar output from the above command:
dpkg: warning: while removing crossover-trial-bin:i386, directory '/opt/cxoffice/lib/python' not empty so not removed. dpkg: warning: while removing crossover-trial-bin:i386, directory '/opt/cxoffice/etc' not empty so not removed.

The additional pieces will need to be removed manually:
Please be careful with this command!
cd /opt/ sudo rm -rf cxoffice/

Now that you are in a clean state, download the latest version of CrossOver and continue with the installation instructions.

At the time of this writing, 13.0.1 is the latest version of CrossOver.


Update your packages:
sudo apt-get update

Change to the directory where bin installer is located and make it executable:
chmod +x install-crossover-13.0.1.bin

Then install it:

The caveat with the .bin installer is that it will install whether the libraries CrossOver needs to run are present or not. CrossOver currently needs the following packages to be present in order to work as expected.

for 64bit:
apt-get install liblcms2-2:i386 libx11-xcb1:i386 libasound2:i386 libc6:i386 libcomerr2:i386 libcups2:i386 libdbus-1-3:i386 libexpat1:i386 libffi6:i386 libfreetype6:i386 libgcc1:i386 libgcrypt11:i386 libgnutls26:i386 libgpg-error0:i386 libgssapi-krb5-2:i386 libice6:i386 libk5crypto3:i386 libkeyutils1:i386 libkrb5-3:i386 libkrb5support0:i386 libp11-kit0:i386 libpciaccess0:i386 libpng12-0:i386 libsm6:i386 libstdc++6:i386 libtasn1-3:i386 libuuid1:i386 libx11-6:i386 libxau6:i386 libxcb-glx0:i386 libxcb1:i386 libxdamage1:i386 libxdmcp6:i386 libxext6:i386 libxrandr2:i386 libxrender1:i386 libxxf86vm1:i386 zlib1g:i386 libudev1:i386 libxml2:i386
After the above is completed, the following command will provide most of the libraries CrossOver makes use of though some libraries may not be necessary:

for 64bit:
apt-get install libfontconfig1:i386 lib32nss-mdns libxslt1.1:i386 libxcursor1:i386 libxcomposite1:i386 libtiff4:i386 libosmesa6:i386 libopenal1:i386 libmpg123-0:i386 libldap-2.4-2:i386 libgstreamer0.10-0:i386 libgstreamer-plugins-base0.10-0:i386 libxinerama1:i386 libxi6:i386 libv4l-0:i386 libsane:i386

Miscellaneous Information

CrossOver 12.5.1 is the first version with true multi-arch support

Ubuntu 12.04 is the first version with skeleton support for multiarch. So why don't they play nicely?

"In 12.04, the package management tools have not fully been updated to be multiarch-aware."

In that, there are varying degrees of bugs with implementing multiarch support that are not resolved with Ubuntu 12.04 and may never be resolved in Ubuntu 12.04. Because of this, it's nearly impossible to properly support Ubuntu 12.04 with a debian installer.
Last modified on 2014-10-23 13:08:49 by Caron Wills
Are you sure you want to delete this page?
Note: Any nested pages that are under this one will be moved up one level. Any attachments tied to this page will be deleted.
Move / Rename Page
Unknown Error, unable to move!
That page exists already!
One or more of the parent pages specified in new path do not exist!
/support/wiki/ /support/wiki/linux/faq/Ubuntu/PrecisePangolin
CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...