CrossOver Support

Installing .deb give error Dependency is not satisfiable: dpkg (>= 1.16.5)


For use with CrossOver 12.5.1 and newer. CrossOver 12.5.1 is the first release of CrossOver that is multi-arch enabled.

Unfortunately this means some distributions will no longer be able to use the debian installer. Ubuntu 12.04 is one of the distributions that is not functional with CrossOver 12.5.1 or 13.0's debian installer.

If you receive this error, please defer to the ".bin" installer available here.

Installing .deb gives error Can't Satisfy Dependencies


Deprecated, for use with CrossOver 12.5 and older

Ubuntu comes with two package managers, dpkg and apt-get. dpkg can install .deb files on the local computer, but can't download dependencies from the net. While apt-get can download files from the net but not install local .debs. Since Crossover Linux is a local .deb, but also needs dependencies downloaded from the net, neither tool will work. So we need to get package manager that can do both.

First, for Ubuntu 12.10 and up, add the 32bit architecture to your libraries. Ubuntu 12.04 users can and should skip this step:

sudo dpkg --add-architecture i386

Then, update the package managers:

sudo apt-get update

Next add the 32bit packages.*

sudo apt-get install ia32-libs-multiarch

Then install the gdebi package manager which can process both local and remote packages.

sudo apt-get install gdebi

Next use gdebi to install Crossover Linux.

sudo gdebi /your/path/to/ia32-crossover_12.2.1-1_amd64.deb


If problems persist, run:

sudo apt-get -f install

And follow the directions terminal presents to you.


*noting that ia32-libs is no longer available and now depends on ia32-libs-multi or ia32-libs-multiarch
Last modified on 2013-11-04 09:12:48 by Caron Wills
Are you sure you want to delete this page?
Note: Any nested pages that are under this one will be moved up one level. Any attachments tied to this page will be deleted.
Move / Rename Page
Unknown Error, unable to move!
That page exists already!
One or more of the parent pages specified in new path do not exist!
/support/wiki/ /support/wiki/linux/faq/ubuntu_satisfy_dependencies
Please Wait...
eyJjYXJ0IjowLCJ0enMiOi02LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTA5MDI4MzM5fQ==