Run RootsMagic 5 on Mac and Linux with CrossOver

rootsmagic 5 genealogy windows software boxRootsMagic 5, the latest version of the award-winning genealogy software from RootsMagic, is available on Mac and Linux with CrossOver! RootsMagic 5 makes researching, organizing, and sharing your family history easy! Whether you're a beginner or an experience professional, RootsMagic is the right family tree maker tool for you.

How do I install RootsMagic 5 Software on Mac with Crossover?
First, visit the RootsMagic 5 website and download their free version or purchase the full version. Once you have a copy of the RootsMagic 5 software, watch our instructional video on how to run RootsMagic 5 on Mac with CrossOver. Once you have finished watching our short video, try CrossOver FREE. If you like it, be sure to come back to this page to purchase CrossOver at a discounted rate.

Looking for RootsMagic 6? Click Here
Looking for RootsMagic 4? Click Here

We assume your preferred operating system is Mac OS, click here to switch to Linux.
We assume your preferred operating system is Linux, click here to switch to Mac OS.

Click the button above to download the CrossOver Mac trial version (fully functional for 14 days).

Click the button above to download CrossOver Linux trial version (fully functional for 14 days).

Before downloading, we need your Name and E-mail.


Your name is required!


Your E-mail is required!


CrossOver should launch and begin the installation when the above button is clicked.
Click here to download the CrossTie file directly instead.
  1. Click the button above to download the CrossTie.
  2. Click on 'OK' to open the file with 'CrossOver'.
  3. CrossOver will now automatically install RootsMagic 5.

Click the button above to Purchase CrossOver Mac (12 months support) for $59.95

Click the button above to Purchase CrossOver Mac (6 months support) for $49.95

Click the button above to Purchase CrossOver Mac (1 month support) for $39.95

Click the button above to Purchase CrossOver Linux (12 months support) for $59.95

Click the button above to Purchase CrossOver Linux (6 months support) for $49.95

Click the button above to Purchase CrossOver Linux (1 month support) for $39.95

Note: The purchase buttons above will open the CodeWeavers store in a new tab. Close that tab after purchasing to return to this page.

How Well Does it Run?

About Ratings

How-to-Install Video

Srr_OGhzqxk

More Help

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

RootsMagic Error when trying to browse during file backups
Jack Phinney
Jack Phinney
Posted 2012-04-25 17:20
We found a regression in Crossover 11 with RM5 - when trying to backup a file, clicking on "browse" to browse to any directory other than the default (which should be My Documents) will trigger an error message. If you "ok" this error and try again, you might eventually be able to browse to the proper directory.

We're working on fixing this for an update to Crossover. In the meantime you can either (a) use Crossover 10.2, where this doesn't happen, or (b) always backup to your My Documents folder, and then manually move those backup files within finder.
Please Wait...
eyJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTU4MDM0NTA0fQ==