EA App Forum

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Unable to load game library

I've been getting an error message when I try to load my games

"Things are taking a little longer than usual to load up. Hang tight while we try to solve the problem"

I have tried a few suggestions from EA forums but those seems to work in Windows.

I'm using:
Crossver 23.6
Ubuntu MATE 23.10
nvidia 535.113.01
16Gb RAM

I have tried accessing the permissions in System Settings but still no luck... I will take a look at other options and see what works

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjoiZW4iLCJjYXJ0IjowLCJ0enMiOi02LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNzA4NjEzODE4LCJjc3JmX3Rva2VuIjoiU1FudHpGVW5lNGhtUnBiRiIsImdkcHIiOjB9