Star Wars: The Old Republic Forum

This is a community forum and not official technical support. — If you need official support: Contact Us

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

SWTOR - Big Sur 11.1 infinite loading screen issue

Hi guys,

I tried several approaches.

The Launcher works flawlessly and the game is updating without problems. When I press "Play" it boots up, on the first boot the Loading Screen appears and the short movies play, but afterwards it loads infinitly. Like I see the yellow SWTOR cursor and I also hear sounds but it remain on the loading screen with the blue circle spinning.

I am currently on an iMac Pro with MacOS Big Sur 11.1. I already got LOTRO working flawlessly.

I tried also different bottles like windows 7-64 bit windows 10 64-bit,

then i tried activating dxvk, esync etc. its always the same behaviour. Even with swtorfix. it keeps spinning forever. I also tried the step by step guide from the tips section its always the same. Has someone a suggestion?

It's probably the same issue that has plagued SWTOR under Wine and CrossOver from the beginning. Yes, swtor_fix.exe was originally created to fix this, but once newer versions of Wine and CrossOver fixed the problem (probably inadvertently), it was no longer needed and maintained.

In later versions of Wine and CrossOver, swtor_fix.exe actually introduced new issues (crazy latency for one), as it hasn't been maintained since 2016 AFAIK.

Here comes some speculation of my own, so take this with a huge shovel of salt. ;)

I think that the removal of all 32 Bit code in Catalina, and the re-introduction of these libraries in CrossOver lead to revival of the same error that made swtor_fix.exe necessary. It is mainly a problem with the two main processes of TOR not being able to communicate with each other, thus the handoff to the main process is never happening.

For example, SWTOR runs flawlessly in CrossOver 20.0.2 in a WIN10 64Bit bottle under High Sierra, which still supports 32 Bit code, so CrossOver doesn't need to substitute its own 32 Bit libs. As you've experienced, it doesn't work under Big Sur (and probably Catalina as well), because both don't support 32 Bit code.

I'm still waiting on my M1 MB Air to arrive so I can test this theory out (I'm still on my Skylake Hacky with a GTX 1070, thus I'm limited to High Sierra as my OS). When I get it, I will post my results here.

Edit: Do NOT use swtor_fix.exe as it is no longer being maintained and not compatible with newer versions of TOR and CrossOver!

1

I've tried everything what Andreas-Christian Hetzl did.

I tried to install SWTOR both on Catalina and Big Sur, without success - the well known 'infinite loading screen issue'.

I've spent countless hours trying to solve this 32bit SWTOR vs 64bit MacOSX issue, and I'm not sure if I see the light at the end of the tunnel anymore. It's been a headache.

If any of you comes up with new idea, I'd be more than happy to try it though. I'm so desperate to play this game on my Macbook Pro.

1

As far as I saw in the GitHub the SWTOR_FIX is open source. So I will try to create an "updated" version for WINE 20.0.2. Just gimme some time. @Andreas Weik & @Kristof Marton

Guys...bad news. I took a look at the SWTOR_FIX Source files, but I honestly cant find something that would make it incompatible with the actual Crossover version. Like it just tells SWTOR and the launcher to communicate. Maybe I just have to little experience, but I honestly think that its just the final version of the SWTOR_FIX. So nothing there that you can possibly update for a newer Wine version.

Oh my. I did not want to come to this conclusion, but I'll start saving for a Windows PC. Never believed I had to go that far, but...
I even tried running a virtual PC. I won't bore you with the details, but it was ridiculous.

How come that it is sooo damn difficult? This 32bit vs 64bit issue seems like a Gordian knot to me.

Apparently TOR will work under Parallels, albeit maybe with reduced performance. It does work on M1 Macs with a preview version of Parallels and a preview of Windows 10 for ARM.

Look for Andy Tizer's tutorial on how to set it up on YouTube. This is for the ARM version of course.

PS: The guy's name is actually Andrew Tsai. My apologies.

Thank you, I'll make sure to check that out.

I've installed Big Sur 11.1 on my Hackintosh (just using the internal Intel GPU). I'm using the latest public version of CrossOver 20.0.2. Unfortunately, I'm experiencing the same issue when trying to launch TOR. It will hang on the loader screen, not handing off to the main process (I think).

I will submit a bug report to CodeWeavers for this. Let's see what happens. The latest nightly build wouldn't even start up TOR for me, so that's definitely not the right direction.

PS: And yes, swtor_fix.exe will definitely not work! I tried. :P

Thank you Andreas for the Parallels tip. I tried it, although I don't think that will be the right solution for my Macbook Pro. The fans were just going crazy, spinning at 90-92 celsius. Maybe if I would possess one with an M1 chip, it would be definitely better.
I think I'd rather wait if Codeweavers came up with something because the game has just ran so well on high sierra (of course I don't want to revert my OSX back as much), or keep saving for that Windows PC 😊

Yes sadly I also tried the Parallels method and even with VMWare fusion both cranked up I have numerous graphical glitches, that make the game unplayable.

Where can I get the nightly build?

My apologies. I shouldn't have mentioned them. These are only for advocates and beta testers (or "better" testers as they call them). And the issue is actually not between the launcher and swtor itself, because the launcher does start swtor.exe fine.

Swtor.exe starts two main processes, each with quite a few threads, and those seem to be the issue. You can see those, if you open TOR in windowed mode (or cmd-tab out of it) and then start the Windows task manager within TOR's bottle.

Ryan Abhiram from the support just answered my ticket and he said the steam version is working fine with crossover, but i got the same issue. I will try now a clean install.

I tried the Steam variant. Same Problem so dont waste your times. Maybe on the M1 it works on my iMac Pro it clearly does not.

TOR is on Steam?!? Oo°

1

Yes its on Steam, and it works with M1. Tried it on my girlfriends Macbook Air. But it still does not work on my i9 Macbook Pro and neither on my iMac Pro with the 8-core Intel Xeon W. So i think its clearly an issue. You Also do not need to change anything. Install Steam via Crossover just add XNA Framework and DirectX to the installer. Install it. Login to account, install swtor login and ta da its running. Sadly no solution for me as i dont have an m1 and work related i will not switch until all the apps work flawlessly on the m1- and following processors.

1

If you can't switch your Mac for work-related reasons (which I fully understand), I suggest that you buy a small external SSD, install High Sierra or Mojave on it (whatever works for your Mac), and use it solely for CrossOver and older Intel games like SW:TOR.

A 256GB SSD should be cheap to get and is more than sufficient in size for a bunch of older games.

PS: Steam just acts as a launcher and is completely unnecessary for SW:TOR. It just adds unnecessary complexity. I've installed TOR in a completely new Win10 64 Bit bottle running in High Sierra on CrossOver 20.0.2 and it works like a charm.

1

For now I will stay with my Parallels VM machine as I found a fix for the graphical glitches. I don't want to switch systems all the time. Its like when something urgent comes in I need to be able to Alt+Tab out of the VM and do stuff without all the time rebooting into another OS. It's one of the main reasons I play games on my MacOS otherwise I would definitely prefer bootcamp or a Windows gaming machine. Maybe the devs will fix this issue with the upcoming Wine 6.0 Branch when they include it in CrossOver. With Lotro in 4k and DX11 everything Maxed out I have no issues at all. Runs like a charm.

1

Quick update from my side. Apparently this is a long known bug that somehow got forgotten by the devs. They will fix it. Here is the officia support response:

[b]Hi Andreas,

I did some digging and it seems to be a longstanding bug that has not been addressed. You are right it works on the M1 but not on the intel machines which seem to be unusual. I will add this piece of information to the bug, however i do not have a timeline for a fix. There is also no immediate work arounds at this time. I added the bug to this ticket so you can be notified when we have a fix.

Regards,
Codeweavers Support [/b]

2

That's great @Andreas-Christian Hetzl , please keep us posted! Thanks for your efforts. I'm over the moon that this long-known issue could finally get resolved.

This is just tooo funny... OMG, yes, we've reported this bug years ago. And again and again. Last, I submitted a beta report during open beta for CrossOver 20. 😀

Well, finally they seem to address this... At least that's the good part. Yes, please let us know if you hear something new. Thanks a lot.

I sucessfully managed to compile Wine 6.0 which apparently runs fine on MacOS Big sur. I will try to create the bottle for swtor and install it. as this needs to be done all by terminal and I never did that before I need to get some knowledge and tryout. Will report back, if it works.

1

Congratulations!

Can you please let me know what you needed to do to compile Wine 6.0? I've used Wine extensively before and know how to use it via Terminal. Maybe we can assist each other.

Yout need homebrew and macports:

https://brew.sh/index_de

https://www.macports.org/

First add my tap

brew tap gcenx/wine

Next

brew install --cask --no-quarantine gcenx-wine-stable

This will install Wine 6.0 into /Applications and function as the official brew cask would (but doesn't require XQuartz)
The --no-quarantine flag is required so brew skips adding the quarantine mark causing gatekeeper prompts this breaks wine packages on macOS Catalina and later.

gecko & mono are included;

Otherwise I honestly dont know how to use it. So Im kind of stuck. Command for Terminal is wine64 winecfg for the config

I also tried getting a clue out of the install script that most people use for before X64-Only OS Systems:

https://github.com/AgentRG/swtor_on_mac/blob/master/install.sh

I dont know how to use wine and how to set it up. So maybe you could help me out if you get it working. Thanks!

Hello,

After several years under Windows, here I am back in the world of Apple with a 2020 iMac 5K. I could not wait for the release of the next iMac ARM, but reading this topic I should perhaps have!

Like you, I'm a SWTOR player and it's my only MMO that doesn't have a macOS version. I first tried through a virtual machine under Fusion by allocating as much graphics memory as possible, but it remains unplayable ... Same with Parallels.

My test using the demo version of CrossOver gives the same result as you, the loading screen keeps looping. I would have put macOS Mojave on an external SSD, but it won't work as my iMac is too new. My only option is therefore the dualboot for the moment.

PS: Sorry for this English worthy of Google translation, I am French :)

Work with version 21.0 on Intel CPU !
Thanks Codeweavers ! 😍

1

Guys I’m a huge noob, first time doing this. Just got a new MacBook Pro (M1) and didn’t even realize SWTOR isn’t for Mac. Can someone reply with a detailed tutorial? I tried downloading PlayOnMac but the wine board is empty and it gives me and error when installing the SWOTR program.

Well, it's not that hard, but you have to get used to some Windows terminologies.

  1. Download the SWTOR installer from the SWTOR website. I take it you know how to do this.
  2. Open CrossOver.
  3. Create a Win10 64 Bit bottle and call it... any way you like.
  4. I usually install the standard fonts next, but SWTOR will work without them. Just... fugly.
  5. Click on the "Run Command..." gear. A window will pop open.
  6. Click on the "Browse..." button in the "Run Command" window. Another window will open.
  7. Navigate to the location where you stored the SWTOR installer and click on it, then click the "Open" button. Window will close.
  8. The "Command:" field should be populated with the path and name of the SWTOR installer program. Click the "Run" button.
  9. SWTOR installer should start and go through the motions. Of course you should've set up an account with them prior to doing this. The actual install should run through without any issues. It will also install the necessary prerequisites.

There's really nothing much more to it. Several shortcuts to TOR and other stuff should show up in the CrossOver window. There will also be a new folder in your user folder called, hold it, "Programs". When you open it, you will find shortcuts (sometimes even with their Windows icons) to the programs you just installed. You can even drag them to your dock; just like any Mac program. It's really just a small app that will open CrossOver and then the program that you wanted.

Mind, this is not an exact science! You are trying to run a Windows program under MacOS. Be prepared for problems.

Let us know if you have any other questions. We will try to answer them to the best of our abilities.

Edit: You WILL have to use CrossOver. Wine on its own will NOT work. And you don't need any Winebottler stuff or other things. CrossOver alone is completely sufficient to run TOR.

One more thing: You are running an x86 program for Windows on an M1 Mac under MacOS. I need to stress this again. Even though your MacBook is pretty powerful, much more powerful than the requirements necessary to run TOR, you will encounter stuttering, lag and other issues. I suggest running in medium quality. And even then it can get bad. I actually set quality to ultra and then set the shaders to low. Resolution 1920x1080 on my 16:9 monitor. It works, it looks ok, and performance is bearable. Good enough for questing, but for ops and flashpoints you might want to lower the graphics quality considerably.

Hi there. My two cents on this issue:
The launcher starts, I enter my login name and password, hit enter and the hanging begins, indefinately.
If I run taskmgr.exe I see two winewrappers running. I killed the first one and suddenly the login process continued.
I could play like no issue had occurred. Afterwards the issue did not occur anymore. (so far)

Of course I have no idea what I just did. Just describing what I see happening. Hope it helps some of you.

Any update to this? I just bought Crossover, and when I install SWTOR using the current executable, the launcher loads and patches just fine. Once I log in, SWTOR itself hits me with a splash screen graphic (and blacks out my other monitors) and never proceeds from there.

Hey, Chris.

Unfortunately you don't let us know what version of macOS you're running and also what Mac you have.

It works "fine" (meaning, it runs, but badly playable) on my MacBook Air M1 under the latest Ventura beta. As you've maybe read up-thread, Intel users (funnily) seem to have a hard time getting it to run, but it should work on the M1.

Playing it on an Intel machine is usually much preferable than on an M1, as it runs so much better there. You may try the tip from Bart who posted directly above you, but other than that, it's still in CodeWeavers hands.

Apparently they were supposed to fix this about two years ago. Not sure what happened. I've largely given up on gaming on the Mac side, as it's just too much of a hassle now with M1-Macs (which I love for everything else).

Too many game developers shun Macs, and using a crutch like Crossover or Parallels is not going to help you when running on an M1 Mac.

Sooo.... I play on my old PC when I want to scratch that itch.

1 to 33 of 33

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjoiZW4iLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNzA4NjEzODE4LCJjc3JmX3Rva2VuIjoiWlB1VWZWa04zZjk1Z2JlciIsImdkcHIiOjB9