Mostly we code...sometimes we write. Every once in a while, we podcast.

Presenting CrossOver 22.1 — The hallmark of this holiday


We know our users have been hearting for an upgrade, especially for 32-bit DirectX 10/11 games on macOS. So we built you a Valentine with oodles of fixes in CrossOver 22.1. And our biggest discount of the year, thus far. Save 25% with the deal code CUPIDisSTUPID on CrossOver+ for macOS, Linux and ChromeOS.*

The games of love…for macOS
The hallmark of this release is 32-bit DirectX 10/11 games on macOS. Games that are now playable include Command and Conquer Remastered Collection, Total War ROME II - Emperor Edition, BioShock Infinite and Magicka 2.* Additionally, GTA Online is no longer crashing and Ubisoft Connect works again.

Other improvements on the gaming front include:

  • An update to the SDL version to improve controller support, specifically rumble support
  • The Xbox Elite Series 2 controller now works
  • Over 400 updates to wined3d from upstream Wine
  • An update to vkd3d to version 1.5

**These are just a few examples of popular games that are now working. Try your favorites to see if there are any improvements with CrossOver 22.1, and if there are drop it in the comments. We’d love to hear from you!

Every bit of our love…for Linux
A crash with Adobe Acrobat Reader 11 and CrossOver is now fixed. Woot! Woot! And the dependency issues for Fedora 37 and OpenSUSE Tumpleweed is repaired.

Sweet new CrossOver…for all
We’re happy to report that this release has several translation updates, including Turkish, Hindi, Indonesian, Slovak, Romanian and Ukrainian.

Not in the official CrossOver announcement, but the Steam beta client is now working again on both MacOS and Linux!

I’m the upgrade, nice to meet you…
Customers with active support entitlements will be prompted soon to upgrade to CrossOver 22.1. Alternatively, they can download the latest version from https://www.codeweavers.com/ac...

If CrossOver asks for registration, use your codeweavers account email and password to register and unlock CrossOver. Email info@codeweavers.com if you need more help.

*CUPIDisSTUPID — 25% off CrossOver+
If you need to purchase a new license of CrossOver, use the deal code CUPIDisSTUPID. Valid on CrossOver+ only for macOS, Linux and ChromeOS. Offer expires at midnight February 21, 2023.

Thank you so much for your support! We hope you enjoy CrossOver 22.1! Now...to get to work on CrossOver 23.

Be well,

Jana


About Jana Schmid
Jana has been working in the marketing profession for over 15 years. She joined the CodeWeavers marketing department in 2010 and has earned oddities such as the Margaritaville Tahiti Frozen Concoction Maker and a lifetime supply of sparkling water for her performance as Marketing Director. Contact Jana at jana@codeweavers.com and learn more about her professional accomplishments on LinkedIn.

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Do any EA App launcher games work?

Sadly, no. EA App replaced Origin, and it's totally borked. We're hoping to have it fixed for CrossOver 23.

3 1

That’s a great V-Day gift! Before I pay to upgrade, does Star Trek Online now work again? It stopped working when the launcher would no longer run as it was 32 bit.

1

No, there were issues beyond getting 32-bit DirectX 10/11 working :/ Hope we'll get that one soon!

I'm more interested on how this actually works as IIRC DX 10/11 is implemented using Vulkan, and Vulkan on macOS (MoltenVK) is built on Metal which doesn't have 32-bit library. Did you guys actually bridged everything graphics related to 64-bit code?

1

Congratulations on the release!

Out of curiosity: how is DX12 support coming along on Crossover for Linux? I know a lot of effort has gone into adding DX12 support to Wine, thanks to which the Steamdeck is now able to run the DX12 version of e.g. The Witcher 3 (next-gen edition). Can we expect to see DX12 enabled on Crossover soon?

1

Any news on AoE 4 support pls? I know that there is an issue with some special library, but surely this can be solved by emaulator?

Nice update!

I'm wondering if Crossover will let me play Genshin Impact on a Mac Studio.

I've been trying to get Far Cry 3 ( 32 bits Dx11 game ) to run, but I get poor performance ( 15fps en M1 pro mac ).
It seems soo close from being playable !

If you guys can fix that, it would be great !

Haruka Ma wrote:

I'm more interested on how this actually works as IIRC DX 10/11 is implemented using Vulkan, and Vulkan on macOS (MoltenVK) is built on Metal which doesn't have 32-bit library. Did you guys actually bridged everything graphics related to 64-bit code?

Simply, yes.

1

Romain Delsol wrote:

I've been trying to get Far Cry 3 ( 32 bits Dx11 game ) to run, but I get poor performance ( 15fps en M1 pro mac ).
It seems soo close from being playable !

If you guys can fix that, it would be great !

Please submit a ticket and let us see if we can help you out. https://www.codeweavers.com/support

Jose Castellon wrote:

Nice update!

I'm wondering if Crossover will let me play Genshin Impact on a Mac Studio.

It looks like Genshin Impact has limited functionality according to our compatibility database.
https://www.codeweavers.com/compatibility/crossover/genshin-impact

But you can always try it for yourself with our two-week, free and fully functional trial.
https://www.codeweavers.com/crossover/download

1

Geert wrote:

Congratulations on the release!

Out of curiosity: how is DX12 support coming along on Crossover for Linux? I know a lot of effort has gone into adding DX12 support to Wine, thanks to which the Steamdeck is now able to run the DX12 version of e.g. The Witcher 3 (next-gen edition). Can we expect to see DX12 enabled on Crossover soon?

We do have limited DirectX 12 support for Linux right now, and we're working very hard on improving the number of DirectX 12 games that run. What game in particular are you interested in running?

1

Any chance of getting some old GOG games to work with Apple Silicon Macs? I've never been able to get Railroad Tycoon II or Deus Ex to run.
But they work ok on my Intel iMac.
Its very frustrating, is their a setting that needs to be checked on special method to getting these old games working?

Nice Update so far.
Just one thought. Will we get Wine 8 in Version 22.x . This might give even more possibilities (hopefully 😉).
Kind Regards
Markus

Markus Kraetzschmar wrote:

Nice Update so far.
Just one thought. Will we get Wine 8 in Version 22.x . This might give even more possibilities (hopefully 😉).
Kind Regards
Markus

I can promise you that CrossOver 23 will based on Wine 8.0. We will be getting version 23 out before the end of the year!

2

David Kingsnorth wrote:

Any chance of getting some old GOG games to work with Apple Silicon Macs? I've never been able to get Railroad Tycoon II or Deus Ex to run.
But they work ok on my Intel iMac.
Its very frustrating, is their a setting that needs to be checked on special method to getting these old games working?

I would suggest that you submit a support ticket at https://www.codeweavers.com/support and let's see if we can help you figure this out.

Star Trek Online seems to play fine (some tearing but it's playable), you just have to turn off dynamic lighting and lighting 2.0. What other issues were you seeing?

Half-Life still runs poorly. Even with the new update it still runs badly.

1 to 19 of 19

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjoiZW4iLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNzA4NjEzODE4LCJjc3JmX3Rva2VuIjoic2dxR1BIWWFSZXNzekpZTCIsImdkcHIiOjB9