CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

.net 1.1 SP1 fails to install

Arch Linux 64bit
I am not able to install .net 1.1 SP1. I have tried installing from the automated installer as well as manually (using the installer downloaded from microsoft website).
Of course prior to this I have already installed in the bottle the .net 1.1
I have tried in empty bottles without anything else inside and it fails consistently.
Any ideas are welcome.

.net 1.1 installs fine on my Arch64 box, so I figure you have some libraries missing.

Use cxdiag that you will find either in /opt/cxoffice/bin or ~/cxoffice/bin. That will list the libraries that it considers as missing, and why. From that, you can choose to install what you think is missing.

After that, we can move forward.

Hi,
thanks for the reply.
Just to clarify that .net 1.1 installs fine on my box. It is the .net 1.1 Service Pack 1 that fails to install.
Does .net 1.1 SP1 install fine in your box?
I 'll install what looks relevant and is missing and see what happens.

I read too fast, sorry!

Anyway, the service pack fails. I'll see if I can find the reason on my end later today, as time is short this morning.

That being said, since .net 2.0 should containt anything needed to satisfy .net1.1 SP1, you could alway just install .net2.0, or am I wrong?

Hi,
Hmm, so the failing of SP1 installation is not something extraordinary in my setup...this, at least, is promising that there is a more general reason behind it.
Some applications require sp1 specifically for some reason, even though they normally should be satisfied with .net 2.0.

Well I tried basically every trick I could think of, but it doesn't work. I don't have any idea what to do. You could always open a support ticket. Even if our distro isn't officially supported, if the staff have an idea, I'm sure they'll help.

Thank you for your efforts. I appreciate it.
I have already opened a ticket and the suggestion is to basically "install missing libraries". I tried with those that seemed that they may be relevant but no joy.
I don' t know what else to try. It seems that the issue might be Arch (or Arch64) related, as .net 1.1 SP1 is supposed to be a working/supported library for crossover linux.
If I think of something else I 'll let you know.
Can someone using another distro please confirm that they can(or cannot) install .net 1.1 Service Pack 1 ?

Just tried to install on Opensuse 12.3 x64 install failed.

Out of morbid curiosity, I created a VM with Ubuntu. The service pack crashes just like on Arch. This is happening no matter the distro, and if this is important to Codeweavers, they need to dig deeper. I'm well aware that Arch is unsupported, but this isn't an Arch issue.

Hi,
thanks guys for trying it in other distros as well.
Out of curiosity did you use a 32bit or 64bit Ubuntu in the VM. Just to see if the issue exists in 32bit as well?
So it seems that it is a general issue with crossover in Linux(so far at least confirmed for 64bit).
.net 1.1 SP1 is officially supported in crossover, so codeweavers should provide a solution for this.

By the way, just to note that this is not a regression issue in cx13, as I also had the issue in cx12.5.1
In addition to note that I tried it in 32bit vanilla wine and it has no problem (it is not supported in 64bit wine).

FYI I downgraded Crossover to 12.2.2 Net Framework 1.1 and SP1installed just fine I wonder if after INSTALL you could reinstall 13.0 and get your app to run.
J-P can't believe you Didn't try this : )

Gabrielle D. Profenno wrote:

J-P can't believe you Didn't try this : )

Well, there is only so much time in a day. Most of my day was spend welding/grinding aluminum for the new hard top I'm making on my '81 BJ42 Landcruiser. As much as I like to help out with this issue, there was a project with precedence in my garage, in particular since a got a new welder for the job. I just couldn't ignore my new toy, mostly because I was welding with argon gas for the first time...

And Konstantinos, to answer your question, I had the 64bit ubuntu iso on hand so that's what I used. But, I have yet to really see a difference from pure 32bit. I have been using 64bit Linux of some sort for a long time now, and I can't remember the last time I have had trouble because I'm using a 64bit distro. In fact, I can't even remember the last time I used a 32bit distro...

J-P I was just poking fun at you, your brilliant. I had an epiphany while in my wood lot with my chain saw and tractor. I remembered I had an app that used .net 1.1 SP1 but I had migrated it from an old version of CX? and it was still working. When it was to dark to work out side I gave it a try.

No worries Gary, I knew you were kidding. But stop with the "brilliant" stuff, my ego is big enough as it is, no really.

J-P I have been running 64bit Linux distros for years and very rarely I had a problem as well but it is not something unheard of. Since the initial reports from you guys were negative while running 64bit it looked like a possible reason. Of course this was before being apparent that is a regression issue in the last few cx versions.
The interesting part is that the regression hit the installation of the library instead of running it.
So as reported if you already had a bottle running .net 1.1 SP1 with an older version and you upgraded to a new version of cx there is no problem.
It is also evident that Codeweavers need to fix this.

Stating the possible absence of a library is not being "negative" about 64bit. A missing library could happen on 32bit too, and is certainly not specific to 64bit systems. CXDIAG is used on both 32 and 64 bit systems for that very reason. I never meant anything else either explicit or implied.

In any case, I still can't remember when an actual 64bit related problem gave me trouble about anything.

I agree with you.
Just to clarify, by "negative reports" I meant that .net 11 SP1 was not running under the tested system which happened to be 64bit

It is frustrating when a working app stops working I know first hand as i am required to use IE to communicate with my business partners. When cx13 came out IE became unusable due to a regression in the way java script works in it. The fact is all the regressions we have been talking about are more likely the fault of the new version of wine an not cx it self. The crossover guys will most likely figure nit out after a fashion.
One other thing to consider is test in vanilla wine to see if it response any different if not file a bug report with Wine Bugzilla it wouldn't hurt to have a few more eyes looking at the issue.

1 to 19 of 19

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjoiZW4iLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNzA4NjEzODE4LCJjc3JmX3Rva2VuIjoidWs0WkxIWVJjWWt6d2M5TSIsImdkcHIiOjB9