CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Registration failed (Arch Linux)

I'm having some problems registering my version of crossover.

It's working fine on Arch on my PC, but when I try to register it on my laptop, I get the following error: image

I've installed it via AUR, but got the same error, then I removed it and reinstalled it via the binary provided on the website under "My Downloads" section.

Neither work.

even if I run xcregister as sudo, the problem persists.

Kind regards,
MGlolenstine

EDIT:
I just tried activating it on yet another installation of Arch Linux and it works. So I guess something is wrong with the laptop's installation.
I'm wondering if the problem was, that I installed it via AUR first and it set some permissions on some files and the purge didn't get rid of them.
But then again, why doesn't root work then.
This is such a mistery.

Just to point out I have the same issue with my system. Except mine is Linux Mint 19.3, Crossover 19.0.0. When I run the "unlock", it prompts for email/password, then a "KDE su" window pops up, but it apparently wants the root password (and as a standard Mint install, there isn't one). I have some KDE tools installed (kceconnect, digikam, etc) mbut not the KDE Desktop.

Even running "sudo /opt/cxoffice/bin/cxregister" still causes it to prompt for the root password. It shows some long command it's trying to run, but the text cannot be selected (otherwise I'd have tried it directly from a command line).

EDIT: let me make a correction on that. Running cxregister with sudo doesn't work (rejects the command as it sees my own .cxoffice dir, which is not owned by root). If I do a "sudo -i" then run the cxregister command, it goes through the same steps, and still looks for the root password through KDEsu.

I could paste a screen clip, but the forum won't let me insert the picture.

Hi folks,

It sounds like both of you are having permissions issues. If you haven't already, you can try:

1) Quitting CrossOver to make sure it is not running for the following steps.
2) Downloading the license file from your account order.
3) Placing the file in /opt/cxoffice/etc.

If that doesn't work, please contact our official support team - you can use the "Contact Us" button at the top of this page.

Thanks,
Anna

Yep, that worked here. Thanks.

Thanks issue is fixed.

Hmm, doesn't work for me. On Crossover Linux 20.0.2 on Elementary OS (Ubuntu 18.04).

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjoiZW4iLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNzE1NzkzNDc5LCJjc3JmX3Rva2VuIjoiekVheHUzU1ZaZjVOUVlncCIsImdkcHIiOjB9