CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us



CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.


Reply to Thread Back to Threads

Ubuntu 19.04, Crossover Linux ... battle.net loads, but no games...
Joseph Palmer
Joseph Palmer
Posted 2019-05-06 16:12
So I have Ubuntu 19.04, Crossover Linux...  DVKM loaded...  everything looks good.  I installed the battle.net client, again, so far, so good.   It loads up, lets me choose the game to install, sets it up, everything doing ok.  Try to Play the game, the screen goes blank, then dumps me back to the battle.net screen with a random error message.  Any thoughts?  I have other games running just fine, vulkan is running (I even made sure that vulkanlib1:i386 was installed) ...  I've looked online but can't seem to come up with any solutions...  is there any progress being made here?  I'd REALLY like to kick Windows to the curb and right now, this is the ONLY thing keeping me from doing so...
Anna Lasky
Anna Lasky  Staff Member
Posted 2019-05-06 16:31
It sounds like you are using the general Battle.net crosstie for the install.  Different battle.net games require different environments and dependencies, so we would recommend installing each game using its specific crosstie into a separate bottle.  This way you will have all of the environment requirements for the specific title.  

Thanks,
Anna
Joseph Palmer
Joseph Palmer
Posted 2019-05-07 10:32
thanks for your input!  unfortunately, that didn't work. i searched around and also tried installing DXVK, disabling streaming and even added -dx9 to the command line.  Still the same thing. the search continues...
David
David Raging Atomic Dragon Turbo Chief Senior Advocate
Posted 2019-05-11 15:34
I know for WoW you need to set the battle.net to exit completely at game launch.

Which games are you trying / want might help to get you more precise help

here are some tricks to try https://www.codeweavers.com/support/forums/general/?t=26;msg=211945
Sebastian
Sebastian Advocate
Posted 2019-05-12 02:16
Could you please try disabling DXVK? (right click on the bottle and go to Settings). This worked for me with Hearthstone (with the Hearthstone specific application installation).
And indeed, please use the application specific installation recipes 😉

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

Please Wait...
eyJjYXJ0IjowLCJ0enMiOi02LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNTcwNTQ3NzcwfQ==