CrossOver Support - Community Forums

Important Information These are community forums and not official technical support. If you need official support: Contact Us

CrossOver Linux
Discussion about CrossOver Linux

The following comments are owned by whoever posted them. We are not responsible for them in any way.

Back to Threads Reply to Thread

Can Crossover ChromeOS and Flatpak co-exist?

Recently, my old chromebook was stolen and so I bought a newer one. I followed instructions on the web to install Libreoffice using a deb file and Firefox using Flatpak.

I had to do updates to install the the applications which also changed the version of Python to a version newer than the Python required by Crossover Chromebook. So after working with Vince at CrossOver Support, I deleted Libreoffice and the Flatpak Firefox and started over with a new install of Linux.

Crossover Chromebook installed easily this time. Unfortunately, both Libreoffice and Firefox are not supported by Crossover. The installations both failed or failed to complete.

I'm not sure which it was that changed the version of Python. Was it me using the Libreoffice deb installation or was it from using Flatpak? I suspect Flatpak, but I'm not quite sure.

Thank you for reading my post.

FWIW libreoffice also comes as a flatpak

https://flathub.org/apps/details/org.libreoffice.LibreOffice

1

Yes thank you.

Since my two year older Chromebook was stolen, I cannot check to see if my installing Libreoffice using a deb was the cause of my problems. I've gotten things working for me using an older Libreoffice installed via Crossover Chromebook and an older Firefox for a website that requires Opera or Firefox.

The current Cossover Chromebook has a problem with newer Python versions, so I'll hope than a future version will help me out.

This bump in the road does preclude my switching over to a Chromebox to replace my Linux desktop soon. I'll keep an eye out on what develops.

Please Note: This Forum is for non-application specific questions relating to installation/configuration of CrossOver. All application-specific posts to this Forum will be moved to their appropriate Compatibility Center Forum.

CrossOver Forums: the place to discuss running Windows applications on Mac and Linux

CodeWeavers or its third-party tools process personal data (e.g. browsing data or IP addresses) and use cookies or other identifiers, which are necessary for its functioning and required to achieve the purposes illustrated in our Privacy Policy. You accept the use of cookies or other identifiers by clicking the Acknowledge button.
Please Wait...
eyJjb3VudHJ5IjoiVVMiLCJsYW5nIjoiZW4iLCJjYXJ0IjowLCJ0enMiOi01LCJjZG4iOiJodHRwczpcL1wvbWVkaWEuY29kZXdlYXZlcnMuY29tXC9wdWJcL2Nyb3Nzb3Zlclwvd2Vic2l0ZSIsImNkbnRzIjoxNzE4MDM3Nzg4LCJjc3JmX3Rva2VuIjoiWXBLVXpkcWJ6QVNCZ1luNyIsImdkcHIiOjB9